1

I am trying to install 10.3 XM in my local. I have performed all the steps and when it tries to install the last step it gives this error.

enter image description here

It is creating the Database in SQL as well and creating website also but not able to login in identity server.

Has anyone faced this error?

Here is the log for reference

    [--------- SitecoreCM_UpdateSolrSchema : SitecoreUrl -------------------------]
[SitecoreCM_UpdateSolrSchema]:[Authenticating] https://Demoxmcm.dev.local/sitecore/admin/PopulateManagedSchema.aspx?indexes=all
Error requesting https://Demoxmcm.dev.local/sitecore/admin/PopulateManagedSchema.aspx?indexes=all: The remote server returned an error: (500) Internal Server Error.
[TIME] 00:18:58
Error requesting https://Demoxmcm.dev.local/sitecore/admin/PopulateManagedSchema.aspx?indexes=all: The remote server returned an error: (500) Internal Server Error.
3
  • What do the Sitecore logs say? Commented May 30 at 15:32
  • @marcel i have already added logs in question Commented May 30 at 15:37
  • Those logs don't appear to be from the actual source. You should be able to find a more descriptive error message by drilling down. Commented May 30 at 16:43

6 Answers 6

3

Based on the information provided, I'd like to summarize the key points and add a few more that I encountered during the installation process.

Please review the following points one by one, and I hope it will help to resolve your issue.

  • First, delete all previously installed versions of sitecore. Stop, remove, or disable all running Solr services, and restart your machine before starting the new installation.
  • Ensure that your Sitecore license file is valid and that you have selected the correct file during installation.
  • Ensure you have installed the URL rewrite package (https://www.iis.net/downloads/microsoft/url-rewrite). This is often the cause of installation failure.
  • Make sure to have both SQL Server and SQL Management Studio installed. If only SSMS is installed, it allows the installation and DB creation but won't be able to connect internally because there is no SQL server installed on your machine. Also as you have said in the question that DB is getting created but login does not happen, this point is just a guess from my side, but it is a necessary point to be cross-checked.
  • Check Event Viewer Windows logs application errors and see if you find anything while installation.

Above are all the points that I feel must be checked, and some of them have already been mentioned in the answers provided by others.

Hope this helps and you are able to resolve the issue 🤞 !!!

Remember to inform the group if anything worked for you. This is a common issue and could be helpful for others.

1
  • I have not installed SQL server that's why it was not connecting . I have installed SQL server and it started working . Thank you for this solution Commented Jun 17 at 16:14
1

This can be the cause of the URL Rewrite not being available. As a few sites had reported, this is sometimes caused by URL Rewrite missing from the IIS site. Go into IIS Manager and check out the CM server install

The easiest way to resolve a missing URL Rewrite option is to install it via the official site.

https://www.iis.net/downloads/microsoft/url-rewrite

Refer to this blog for more Sitecore 10.3 installation errors.

https://www.getfishtank.com/blog/resolving-sitecore-xm-graphical-issues

Hope this helps.

1
  • I have tried same step but still same error . I have restarted system as well Commented May 30 at 16:18
1

You will need to install URL Rewrite Module in order to solve this issue, that can be download from below link.

https://www.iis.net/downloads/microsoft/url-rewrite#additionalDownloads

Once the IIS rewrite module is installed, you can find it under IIS manager as below:

enter image description here

Thereafter you can retry the installation. In case you face any issues after this as well, check for event viewer logs.

Hope this helps!!!

2
  • I have tried same step but still same error . I have restarted system as well Commented May 30 at 16:18
  • @GarimaThakore can you look for any error in the event viewer logs...
    – ckhanna
    Commented May 30 at 18:32
1

First of all, check you have installed the prerequisite.

Verify that you have installed URL Rewrite Module.

After installing the IIS URL Rewrite module, reinstall your Sitecore instance again.

0

Please check below steps:

  1. Please check is your Solr is up and running and check the Solr logs too.
  2. Check Event Viewer -> Open Event Viewer on the server -> Navigate to Windows Logs -> Application -> Look for any related errors or warnings around the time of the 500 Internal Server Error
  3. Sitecore Licensing - Ensure that your Sitecore license is valid and correctly configured.

Hope this helps.

0

When you are conducting the installation of Sitecore XM 10.2 or 10.3 on Windows 11, and faced with the error as mentioned in the image. Then you need to take care of following steps:

1.Delete any of the previously failed instances.

2.Verify the SSMS credentials as well as the Solr service with the path.

3.Sitecore Licensing - Ensure that your Sitecore license is valid and correctly configured.

4.Go to Control Panel > Programs and Features > Turn Windows features on or off > Internet Information Services > World Wide Web Services > Application Development Features > Check the options ASP, ASP.NET 3.5, ASP.NET 4.8

enter image description here

5.Firstly, check the above given steps and after they are completed, if the issue still persists, follow the next steps.

6.We have observed that the cause of the problem is that IIS does not have any URL rewrite models. To solve this, go to https://www.iis.net/downloads/microsoft/url-rewrite and install the package that is required.

You will then be able to find a new item which has been created in the IIS packages list. enter image description here

After they are installed, reboot your computer and then install Sitecore again.

Now, you will find that the issue is resolved and Sitecore has been setup completely.

Hope this helps.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.