I'm using the Sitecore URL Rewrite Module found here: https://marketplace.sitecore.net/Modules/Url_Rewrite.aspx

The module allows you to create redirect items. The redirect items have the fields Path and Target. The Path field (Single-Line Text) specifies the path to redirect and the Target field (General Link) is the location to redirect to.

I've used the Target field to insert an internal link to the Home page with the query string sc_lang=test, but the query string is never appended to the redirect URL. Does anyone know, if this is an existing bug with the package?

I've also tried writing out the query string as sc_lang=%3Dtest but that did not work as well. I believe the query string is never being read from the link field in the package code, but I was curious, if anyone else had experienced this issue.

enter image description here

  • 1
    When you set up the redirect in the module did you append the querystring? If so remove it. Also remove any trailing or leading slashes else it won't pick up the querystring correctly and redirect. The module matches on the url and should grab the querystring and forward on to the target url and append the querystring automatically. Thats how it's worked when I've used it anyway. Commented Jan 17, 2017 at 16:10
  • 1
    I am currently going through the nightmare of extending this module with custom conditions and actions (it is badly written and organized code), and I am quite sure that the query string parameter is not being read from the link at all. It only reads the anchor parameter.
    – WulfgarDK
    Commented Jan 20, 2017 at 8:32
  • @WulfgarDK I was pretty certain that was the case but it's nice to know someone else has seen the same thing. Thanks!
    – c-bro
    Commented Jan 20, 2017 at 13:32
  • @AdamSeabridge you da man... Commented Dec 15, 2018 at 8:08
  • yeah it doesnt work with querystrings if you want querystrings just remove them like adam says it should relay them Commented Dec 15, 2018 at 8:10


Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Browse other questions tagged or ask your own question.