9

So, I just upgraded to 8.2 Update 2 along with Glass.Mapper 4.3.4.196.

I now see a ton of Glass.Mapper INFO messages in my logs. This adds a ton of noise to the logs. Is there a reason this is happening or is this normal behavior.

1920 07:45:39 INFO GetModelFromView 0 {25363DC2-49BC-4FB9-84FF-F9164BE6CC3E}
1920 07:45:39 INFO GetModelFromView 0 {25363DC2-49BC-4FB9-84FF-F9164BE6CC3E}
1920 07:45:39 INFO GetModelFromView 0 {25363DC2-49BC-4FB9-84FF-F9164BE6CC3E}
1920 07:45:39 INFO GetModelFromView 0 {54661361-3C46-4AAA-A82B-6D649F43917F}
1920 07:45:39 INFO GetModelFromView 0 {1B427610-DB06-4F5B-AD35-8F1E8B8FD56B}
6720 07:45:39 INFO GetModelFromView 0 {FE5D7FDF-89C0-4D99-9AA3-B5FBD009C9F3}
6720 07:45:39 INFO GetModelFromView 0 {9DC3117B-367E-4510-AB61-490DDC8359A5}
6720 07:45:39 INFO GetModelFromView 0 {FD8ED973-34E5-4544-9886-9269BA4C1227}
6720 07:45:39 INFO GetModelFromView 0 {729DA297-DB63-4362-B835-E3D4E0CC90E5}
6720 07:45:39 INFO GetModelFromView 0 {AF675ECD-84AC-4110-A334-EB1CA2A34452}
6720 07:45:39 INFO GetModelFromView 0 {25363DC2-49BC-4FB9-84FF-F9164BE6CC3E}
6720 07:45:39 INFO GetModelFromView 0 {5281E350-9958-457F-8D37-FD98134FC9A4}
1920 07:45:40 INFO GetModelFromView 0 {9D5CCD1F-4519-4633-BDFE-72AC41131609}
1920 07:45:41 INFO GetModelFromView 0 {25363DC2-49BC-4FB9-84FF-F9164BE6CC3E}
1920 07:45:41 INFO GetModelFromView 0 {5281E350-9958-457F-8D37-FD98134FC9A4}

2 Answers 2

7

I guess is a mistake in code. From my point of view these lines must be on Debug mode not Info mode.

On line 124 we have

 Sitecore.Diagnostics.Log.Info("GetModelFromView {0} {1}".Formatted(watch.ElapsedMilliseconds, args.Rendering.RenderingItem.ID), this);

and this line runs everytime GetModelFromView processor is running.

Please check glass mapper source code :

https://github.com/mikeedwards83/Glass.Mapper/blob/5136ac34f2159d57966e6a499b3318ff3020bb55/Source/Glass.Mapper.Sc.Mvc/Pipelines/Response/GetModelFromView.cs

This should be fixed in Release 4.3.4.197.

10
2

In case you are stuck with this old version, you can protect your logfiles from beeing spamed by adding the following XML to the

<appender name="LogFileAppender" type="log4net.Appender.SitecoreLogFileAppender, Sitecore.Logging">

node in your sitecore.config:

<filter type="log4net.Filter.StringMatchFilter">
  <stringToMatch value="GetModelFromView "/>
  <acceptOnMatch value="false"/>
</filter>

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.