4

Upgraded from WFFM 2.4 to 8.2u1. Forms that already exist is able to add new fields and edit in any way.

If i create a new form and try to press "Add field" in the form designer this error pops up:

enter image description here

Any ideas?

1
  • 1
    please, post the exception stacktrace as text, so that i could be googled in future Jan 24 '17 at 14:58
7

This is caused by a missing sub-item within the Web Forms for Marketers base form creation process. To fix this until Sitecore corrects the issue:

  1. Go into the Content Editor and find your Form
  2. Right click on your form and insert a new Form Section (or select it and use your insert options)
  3. Give it a name

That should get you working again. Until a fix is ready, I have created a basic form with just a "Fields" section and instead of creating a new form, I just click the button to copy from an existing form.

1
  • I made a branch template in wait for this to work, so that the section comes with the creation of a form. Thanks for the workaround tip! Jan 25 '17 at 8:24
3

Sitecore provided a support package for this issue. You can find it under https://kb.sitecore.net/articles/844911.

Just copy the Sitecore.Support.139810.config and the Sitecore.Support.139810.dll from the package to your servers and the issue should be fixed.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.