3

When configuring the source for a Drop List field, both the Value and Text are defaulted to ItemName. I need Display Name for both Value and Text, but there are no dropdowns to select which fields to use. I have seen these in other forum posts' screenshots. Why do I not have these and how do I get them to show up? Is there a back door way to set these? I'm using WFFM 8.0 rev. 141217 btw. screenshot 1

Looking at the css, I found a width attribute. I unchecked it and now see the dropdown arrows. In the list of fields when I select one I get a javascript error. screnshot 2

Debugging the Javascript, it's breaking at line 13, the ListItems.callback call. Looks like QueryKeyHolder is null. Now what am I gonna do with that??? screenshot 3

Per jammykam's suggestion, I tried installing a new instance of Sitecore and installed WFFM on that (same versions) and see the same behavior there. I opened a ticket with Sitecore support, they were also able to replicate the issue and should be sending a patch soon. I'll update this post then.

  • Since you're on a version early version on 8.0 and WFFM (update-1) I'm going to hedge a bet that this is a bug that was fixed in a later release. If you're able to replicate on a clean Sitecore install of the same version I would raise a ticket with Sitecore Support. – jammykam Jan 26 '17 at 15:07
  • Thanks jammykam, I created a fresh instance (same versions) and it has the same issue. If we can't hold off till upgrade I'll take it to support. – Bill Thomas Jan 26 '17 at 17:06
3

I am facing the same issue with WFFM 8.2 rev. 161129 along with Sitecore 8.2 update 2. Initially thinking it was something version specific, tried using rev 170518 with Sitecore 8.2 update 3, but faced the same issue again.

Further analysed the Sitecore.Forms.PopupMenu.js and other list related JavaScript provided with WFFM. Not sure if this is the perfect solution to this issue but adding the below line of code did the job for me:

this.show = function(event, controlid, height, width, args) {
      window.Sitecore.Forms.PopupMenu.args = args;
...

}

It was the missing popup arguments on field selection that were preventing the update.

Adding this as an answer here, as this was the only question that exactly matched the issue I was facing, except for the version difference. Hope it helps.

|improve this answer|||||

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.