7

I've created some PSE scripts to give our client some reports on their content. I created them under the proper convention of Script Module and Script Library so that the reports show up under Reporting Tools in the Sitecore start menu.

Tree:

tree

Menu:

menu

This works great for an admin. What I can't figure out is how to grant access to these reports to editors. In Core, I've given Read access to /sitecore/content/Documents and settings/All users/Start menu/Right/Reporting Tools/PowerShell Reports. I've also given read access in Master to my script module, script library and individual scripts.

What am I missing to allow editors to see these reports in the Sitecore start menu? With the access changes noted above, they only see an empty Powershell Reports menu.

  • did you try Ribbon -->Security --> Assign options @ Master DB for these reports. – Balaji Kuppuswamy Jan 31 '17 at 4:53
  • 1
    Are you running v4.3 of PSE? There was a lot of work on security in that version and there is a known issue with a misspelled role name in the default configuration: github.com/SitecorePowerShell/Console/issues/765 In short, check the App_Config/Include/Cognifide.PowerShell.config file for the incorrect "sitecore\Sitecore Client User" role and change it to "sitecore\Sitecore Client Users". Since the issue is fixed on github, I assume that the next release will be correct so it should be safe to update the config file directly instead of patching in a separate file. – Jonas Hamnered Jan 31 '17 at 7:49
5

Security Setup

Here are the steps I followed to grant access.

  1. Navigate to the item /sitecore/content/Documents and settings/All users/Start menu/Right/Reporting Tools/PowerShell Reports
  2. Grant access to sitecore\Sitecore Client Authoring

Security Change

  1. See changes.

Report now available


Troubleshooting

Execution Missing

If you see the report menu item but does not expand, ensure that the user has access to the group defined in the configuration for Execution service.

Example: If you decided to use a different group in the above, then be sure to patch the setting below. Issue #765 will be addressed in 4.4, however you can manually fix it.

<configuration xmlns:patch="http://www.sitecore.net/xmlconfig/">
  <sitecore>
    <powershell>
      <services>
        <remoting>
          <authorization>
            <patch:delete />
          </authorization>
          <authorization>
            <add Permission="Allow" IdentityType="Role" Identity="sitecore\Sitecore Client Users" />
          </authorization>
        </remoting>
      </services>
    </powershell>
  </sitecore>
</configuration>

Book Documentation

Instructions from this page have been copied to the book.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.