In a development environment, when I attempt to open the Active Tests window from the Optimizaton tab of the Experience Editor, the window does not finish loading. I opened Chrome Developer Tools, and see that the following request:


receives an error:

"{"Message":"An error has occurred.","ExceptionMessage":"The required anti-forgery cookie \"__RequestVerificationToken\" is not present.","ExceptionType":"System.Web.Mvc.HttpAntiForgeryException","StackTrace":" at System.Web.Helpers.AntiXsrf.TokenValidator.ValidateTokens(HttpContextBase httpContext, IIdentity identity, AntiForgeryToken sessionToken, AntiForgeryToken fieldToken)\r\n at System.Web.Helpers.AntiXsrf.AntiForgeryWorker.Validate(HttpContextBase httpContext, String cookieToken, String formToken)\r\n at Sitecore.Web.Http.Filters.ValidateHttpAntiForgeryTokenAttribute.OnAuthorization(HttpActionContext actionContext)"}"

This is on Sitecore 8.1, update 3, with SXA 1.2.

  • did you check this [possibility of duplicate issue.] sitecore.stackexchange.com/questions/2257/…. Feb 2, 2017 at 5:35
  • Yes, not a solution. That issue just concerns error logs, whereas my issue prevents functionality. Feb 2, 2017 at 7:19
  • I'm unable to reproduce your issue on both 8.1 Update 3 and 8.2 version. I've checked that twice on my local development environment and on our CI. The "Active Test" window opens without issues. Feb 2, 2017 at 8:22
  • Thanks for the update. I"m going to leave this open in calse anyone has an indication where to look. Feb 2, 2017 at 8:59
  • @DanSolovay - possibly solved by this: sitecore.stackexchange.com/questions/4156/…
    – Mark Cassidy
    Feb 2, 2017 at 11:18

1 Answer 1


While doing an install and a reporting database rebuild on a local development environment, I started receiving the exact same error messages on pretty much any SSC web API call. I evaluated all of the links provided in comments, and the one answer that seemed to help me exactly was the forcible removal and clearing of all cookies for the development domain that I was working on.

The Chrome "Clear Cache and Hard Reset" did not do the trick.

Open up Chrome Tools, Go to Application, and right click on your local site, and press the clear button. Then refresh your browser.

enter image description here

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.