0

When we try to open Sitecore Powershell console or ISE after fresh installation on one of the Sitecore instances, we receive below error :

enter image description here

Log Entry for this error is:

3572 06:48:51 WARN Could not find type in ReflectionUtil.CreateObject: Cognifide.PowerShell.SitecoreIntegrations.Applications.PowerShellConsole
3572 06:48:51 ERROR CodeBeside class "Cognifide.PowerShell.SitecoreIntegrations.Applications.PowerShellConsole,Cognifide.PowerShell" not found. (method: Sitecore.Web.UI.HtmlControls.CodeBeside.OnInit(EventArgs e)).

Sitecore version : 8.1 Update 1 & Powershell Version 3.3

  • 1) Please edit your post and include errors as text, not as pictures. 2) Have you checked that Cognifide.PowerShell.dll is present in the site's bin folder? 3) Have you tried reinstalling SPE? – Dmytro Shevchenko Feb 2 '17 at 7:44
  • we have the cognifide*.dll & config files. I haven't tried reinstalling let me try. – Balaji Kuppuswamy Feb 2 '17 at 7:51
  • 2
    You already had this issue last year: community.sitecore.net/developers/f/7/t/3039 A reinstall helped you that time. – Dmytro Shevchenko Feb 2 '17 at 7:54
  • it was in less priority environment where i had full control but at this evn i hav limited access & cannot dig into more. Admin seeking some technical info behind this :( – Balaji Kuppuswamy Feb 2 '17 at 7:57
  • 1
    I got the root cause for this issue. :) As we are aware ( + mentioned in the answer) there is a conflict in powershell version between installed & deployed. RootCause: we have initially installed sitecore PS version of 3.3 but unfortunately dev team-A has added old powershell version (2.8) in their web project. Hence after each deployment, we were able to see this strange behaviour. – Balaji Kuppuswamy Feb 6 '17 at 14:59
1

There can be different factors that causing this issue:

1. Version Compatibility

  • SPE version is not compatible with the Sitecore version.
  • Powershell version should be in sync across all the environment if development code base is having powershell dll reference.

2. Package Installation

  • The package is not installing properly whereby some files are not getting installed accordingly.

I will tend to go for the 2nd point since the error shows that it cannot create an object from Cognifide.PowerShell.SitecoreIntegrations.Applications.PowerShellConsole,Cognifide.PowerShell.

Seems like the assembly Cognifide.PowerShell is not properly installed. Try to make sure that the proper security permission (write/read) is set on the website folder including subfolders.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.