3

I installed Data Exchange Framework, Sitecore Provider for Data Exchange Framework, and Dynamics CRM Provider for Data Exchange Framework (all 1.2.0 rev 161212) in my Sitecore instance. I have tested the connection and confirmed that a connection with Dynamics CRM is established. enter image description here

And when I'll try to run a pipeline batch, the Run Pipeline Batch is grayed out (disabled) and can't be clicked for every pipeline batch. enter image description here

This is strange because I had this working once in a different instance with same versions installed (I was able to sync Accounts aside from the default Contacts etc). But when I created another and another one, both buttons are disabled. I've followed the walkthrough but this is really bothering me for almost two days now. Thanks a lot for your help!

8

When you create a new tenant it is disabled by default.

You need to enable it. On the tenant item on Administration section you have a checkboxfield Enabled

Please see below image:

enter image description here

You can enabled or disabled a single pipeline batch.

On the pipeline batch processor item on Administration section you have a checkboxfield Enabled Please verify if is enabled, maybe someone else disabled it.

enter image description here

  • Oh my! The tenant item itself is not enabled but the pipeline batches are. Thanks a lot! – Judah Endymion Feb 3 '17 at 1:32
3

The one of the way do not forget enable tenants or pipeline batches before running you can use a custom extension - "Gutters for Sitecore Data Exchange Framework".

enter image description here

enter image description here

  • This one's very handy and helpful, thanks for sharing this! – Judah Endymion Feb 3 '17 at 10:07

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.