2

I'm using SXA 1.2 on Sitecore 8.2. I've created a website in my development sandbox, and am trying to share it with the other developers on my team. So, I did the following steps:

  1. Create a new tenant on my sandbox
  2. Create a new website in that tenant
  3. Use TDS to grab the Tenant Folder, Media Library/Project/Tenant Folder, and Templates/Project/Tenant Folder.
  4. Commit those changes to the source code repository
  5. Have a team member get the new project and sync with Sitecore

Most everything seems to work. The website shows up and is browsable. However when that other developer clicks on the Export button on the Experience Accelerator ribbon, they get this message: Export Error

This same action works fine in my original site. I'm guessing that I've missed a template or sitecore setting somewhere that is preventing the Export from working properly. I've done multiple comparisons between the 2 websites, and can't find the setting. Here are my questions:

  1. Does anyone know what setting is needed for this export function to work?
  2. Is there a better way to keep the SXA websites synchronized between developers?

Update I have been trying several different things, and now it appears that my other developer can't create a new website in the tenant that we've synchronized. When they try to do that, he gets an SPE error, and that log says:

Script item set to master:\system\Modules\PowerShell\Script Library\SXA - Scaffolding\Content Editor\Insert Item\Site in ScriptSession $scriptSession$|2lfpui5jwv3yfyhnitfugd3i|e3ecec93-a94b-485d-bcfe-d69772218312.
ManagedPoolThread #2 16:18:25 INFO  Executing a script in ScriptSession '$scriptSession$|2lfpui5jwv3yfyhnitfugd3i|e3ecec93-a94b-485d-bcfe-d69772218312'.
ManagedPoolThread #2 16:18:26 ERROR Unrecognized Guid format.
ManagedPoolThread #2 16:18:26 INFO  The script execution in ScriptSession '$scriptSession$|2lfpui5jwv3yfyhnitfugd3i|e3ecec93-a94b-485d-bcfe-d69772218312' completed in 801 ms.

I'm guessing that the 2 errors are related, although I don't really know how. Any suggestions?

  • Did the developers publish after the import? Then the ExportButton should work – Lars Schilling Feb 13 '17 at 15:07
  • Did you ever overcome the issue? I just helped a developer setup an instance and we see the same problem. We do have the items pointed out by Dawid. – Michael West Mar 2 '17 at 18:59
  • No, I'm still working on this issue on and off. I've tried everything suggested and still no luck. – Keith VanderVeen Mar 2 '17 at 22:41
1

If you your default Sitecore Homepage still exists, make sure you're using the domain name you put in the Host Name field of your SXA site item to access Sitecore.

For example, if Sitecore was setup to use www.mysite.com, and your SXA Host Name is sxa.mysite.com, be sure to use sxa.mysite.com/sitecore to access the Experience Editor.

The system doesn't have the context of the SXA site when you login with www.mysite.com/sitecore.

enter image description here

That's what did it for me. Hope this helps.

1

Creative Exchange is using Storage Definition Items to allow the user to configure possible outputs of Creative Exchange. Those items are stored /sitecore/content/Test/Site/Settings/Creative Exchange Storages and that is what is probably missing on your new website.

Take a look here:

enter image description here

Those two items visible above are later (while exporting) available here:

enter image description here

Regarding website synchronisation - we are doing the same but instead of TDS we are using Unicorn. So the items are serialized with Unicorn and stored in repository.

  • That's what I figured, and that's why I grabbed the entire website folder. I already had that information. – Keith VanderVeen Feb 9 '17 at 22:31
0

OK, so we were finally able to figure out how to solve the problem: We had to upgrade our SXA install to use 1.3 Update 1. We hadn't touched this project for a few months, and decided to go ahead and start with the latest version of SXA. We synced with TDS, and now everything seems to be working fine.

I hope this helps someone else!

0

In my case , i had to create the folders manually in the system as per the configuration and it stared working . enter image description here

The creativeExchangeFolder path can be found in the config file "App_Config\Include\Feature\Sitecore.XA.Feature.CreativeExchange.config"

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.