1

I'm going to explain the issue with a quick example.

I have a Folder item based on 'Folder Template', which is bucketable. I have 2 other templates - Page Template 1 and Page Template 2. The items based on Page Template 1 and Page Template 2, are actually within the Folder item as bucketable items.

I created Page Template 3 and tried to include it in Folder item as a bucketable item but whenever I create this item, it gets created as a regular item and not as a bucketable item.

Page Template 3 is essentially a copy of Page Template 2, with a few different components on it but for some reason acts differently.

Has anyone noticed this behavior?

Thanks

1

Make sure you have set Is Bucketable on the standard values for templates that you want to be able to store inside a bucket.

A bucket can have items based on many number of content templates.

For your Folder Template to be an item bucket, you have to select it and click on the Bucket button in the Configuration ribbon. Once it is a bucket, if you have correctly set Is Bucketable to true on the standard values of Page Template 3 it will be stored as a bucketable item.

  • Page Template 3 has Bucketable as true and Is Bucket as false, same as Page Template 2. But still the issue persists. – Gabbar Feb 10 '17 at 0:53
  • Is that on the template or the template std values? – Richard Seal Feb 10 '17 at 1:12
  • standard values of page template 3 – Gabbar Feb 10 '17 at 1:18
  • I figured it out. For some reason the branch did not get that setting propagated from the standard values of page 3. Once I fixed it all worked. – Gabbar Feb 11 '17 at 0:27

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.