1

Anyone have an issue installing Coveo for Sitecore (Cloud) module "82 4.0 (895).zip" on Sitecore 8.2 Initial Release with WFFM?

Coveo said it is a known issue https://support.coveo.com/s/article/ka132000000LLs7AAG/1912 but even with the patch it locks up my Sitecore instance. Any ideas?

4

We have updated the support article.

This issue occurs due to a deadlock between Web Forms for Marketers and Coveo For Sitecore in Sitecore 8.2.

An Hotfix has been created by the Sitecore team, but for it to work, a specific installation order must be followed. Additionally, a value in the Coveo.SearchProvider.config must be set to "false" temporarily (it must be set to true for Coveo For Sitecore to work properly.)

Here are the installation steps:

  1. Install the dll inside the Instance bin folder and copy the Sitecore.Support.137437.config file into the App_Config folder.
  2. Install WFFM
  3. Install Coveo for Sitecore
  4. Set <initializeOnAdd>false</initializeOnAdd> in the Coveo.SearchProvider.config file
  5. Restart IIS
  6. Finish configuration for Coveo in the Sitecore Control Panel.(Synchronize, Reset Security Cache, Reset Permissions on the Actions page)
  7. Rebuild the Coveo indexes
  8. Set <initializeOnAdd>true</initializeOnAdd> in Coveo.SearchProvider.config file (Important or Coveo for Sitecore may not work properly)
  9. Restart IIS
  10. Perform the Configuration of Coveo again(Synchronize, Reset Security Cache, Reset the Permissions on the Coveo Actions page)
  11. Rebuild the Coveo indexes

The hotfix can be obtained by contacting the Sitecore Support team.

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.