1

All of a sudden, Whenever I try to use the Sitecore experience editor, I get the error: The item "/sitecore/content/Applications/WebEdit/WebEdit Texts" was not found. It may have been deleted by another user.

I've checked that item, and it definitely exists. I found an article (https://codebuildplay.wordpress.com/tag/error/) that suggests that this error is a caching issue, but I've ruled that out.

Any ideas on what might be causing this?

The specific error ini the error log is:

Nested Exception

Exception: Sitecore.Exceptions.ItemNullException Message: The item "/sitecore/content/Applications/WebEdit/WebEdit Texts" was not found.

It may have been deleted by another user. Source: Sitecore.Kernel at Sitecore.Client.GetItemNotNull(String itemPath, Language language, Version version, Database database) at Sitecore.Xml.Xsl.ImageRenderer.GetDefaultImage() at Sitecore.Xml.Xsl.ImageRenderer.Render() at Sitecore.Pipelines.RenderField.GetImageFieldValue.Process(RenderFieldArgs args) at (Object , Object[] ) at Sitecore.Pipelines.CorePipeline.Run(PipelineArgs args) at Sitecore.Mvc.Helpers.SitecoreHelper.BeginField(String fieldName, Item item, Object parameters) at Sitecore.Mvc.Helpers.SitecoreHelper.Field(String fieldName, Item item, Object parameters) at [XXXXX]_cshtml.Execute() in [XXXXX].cshtml:line 75 at System.Web.WebPages.WebPageBase.ExecutePageHierarchy() at System.Web.Mvc.WebViewPage.ExecutePageHierarchy() at System.Web.WebPages.WebPageBase.ExecutePageHierarchy(WebPageContext pageContext, TextWriter writer, WebPageRenderingBase startPage) at System.Web.Mvc.Html.PartialExtensions.Partial(HtmlHelper htmlHelper, String partialViewName, Object model, ViewDataDictionary viewData) at Sitecore.Mvc.Presentation.ViewRenderer.Render(TextWriter writer)

  • Any errors in your Sitecore logs? Also, is it possible a new patch config was introduced that could be causing this? Can you compare the output of the /sitecore/admin/showconfig.aspx page for this site with a clean install of the same version? – DougCouto Feb 23 '17 at 12:23
  • I have also recently experienced this issue. I have not solved the problem yet. But I determined, that when trying to access the "/sitecore/content/Applications/WebEdit/WebEdit Texts” item, the Sitecore.Context.User is "sitecore\anonymous". I am not sure if that is as intended. But if I wrap the code accessing the Item in: using(new SecurityDisabler()) I am able to read the item. Hopes this guides you in the right direction. Please post the answer, if you find a solution. – Peter Vestergaard Feb 24 '17 at 13:05
  • The error seems a very weird error, maybe have you tried generating a Sitecore package of that core item from another Sitecore instance of the same version and reinstalling it on the version you are getting the error? I am wondering if the error is related to some corruption at the DB item level. – Carlos Araujo Feb 27 '17 at 15:39
3

Assuming that you use Chrome, I've seen this error a couple of times myself, and it seems to be related to caching within the browser itself (which is why it can appear randomly).

A colleague of mine had this issue and was suggested trying a different browser. Once he fired up firefox, everything worked fine. Once he deleted all the cache from Chrome, and the error disappeared.

You can read the full story over here: https://codebuildplay.wordpress.com/2016/08/10/webedittexts-not-found/

| improve this answer | |

Not the answer you're looking for? Browse other questions tagged or ask your own question.