2

I have noticed this strange error in my instance after attempting to connect sitecore rocks with my local sitecore instance which I have recently migrated to solr from Lucene search provider.

Actual Issue:

I have been playing around with sitecore rocks for long time & it was with Lucene enabled instances. All (including mine) instances were migrated to SOLR provider & when I tried to connect Sitecore rocks with my local instance, I have received ‘Connection failed’ even after deploying Sitecore rocks component dlls & service files. Now when I try to access sitecore login page or any page, I have received this error.

enter image description here

Some Analysis:

There was no much information and also specially no errors in the sitecore logs & I have started disabling all config files step by step but which went in vain. When I had a close look at the log entry, I see log entry stopped logging soon after ‘Sitecore.Rocks.Server.dll’ & it should have recorded ‘Sitecore.Rocks.Lucene*.dlls’ log entries Which were missing.

enter image description here

Temporary solution: As soon as i delete ‘Sitecore.Rocks*.dlls including ‘Sitecore.Rocks.Lucene*.dlls’ I’m able to get the sitecore login page. :)

Queries: Do we have Sitecore rocks for solr enabled sitecore instance ? or should I perform any alternate steps to connect my local instance(SOLR enabled) ? If no, are we restricted to connect Sitecore rocks only if your instance is with lucene search ? :(

3

Please look on changelog of Sitecore Rocks Github Repository. Looks like you don't need on this version ‘Sitecore.Rocks.Lucene*.dlls. Please make a new install of the module and see if you still have the error. If you still have please delete Sitecore.Rocks.Lucene*.dlls and other dll that are not needed anymore.

https://github.com/JakobChristensen/Sitecore.Rocks/blob/03c1f02eb1487feab431614ef1bde1bf65440bd9/CHANGELOG.md

enter image description here

  • it could be a big workaround if we stick with older version of sitecore rocks + solr enabled sitecore instances. ? – Balaji Kuppuswamy Feb 27 '17 at 5:37

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.