Hi I am setting up a commerce site following this tutorial here: http://commercesdn.sitecore.net/SitecoreCommerce/DeploymentGuide/en-us/index.html#Concepts/c_SC_SetUpCommerceServerSite.html

but when I run the Initialize-CSSite command in Windows PowerShell, I get the following error:

The operation cannot be performed because this Commerce Server instance has not been configured. Please run CSConfig.exe to configure Commerce Server.

If I run the CSConfig.exe I get:

The term 'CSConfig.exe' is not recognized as the name of a cmdlet, function, script file, or operable program.

I am assuming I need to import a module for this? Does anyone know how to address this issue?

Also I see the CommerceServer.Core.config file under App_Config for my local website folder.

  • are you running Powershell script as Admin ? Mar 2 '17 at 15:05
  • yeah. I`m at this point reinstalling CS to see if that does any good.
    – Diego
    Mar 2 '17 at 15:16
  • You need a lot of cofee to install this module :) Mar 2 '17 at 15:26

The problem with the CSConfig was that CS was failing although the message on the wizard was that it was complete. It did not show any error messages. Reinstalling with elevated privileges and leaving the default administrator user properly installed CS. After that I was able to run the Initialize-CSSite command. hope this helps anyone


I just had this issue myself. In essence, I had a typo in the AppPool account used to run the CSServices website, so the account failed to log in properly and therefore stopping the AppPool.

This lead to the above.

I did some further testing. In general this error message is pretty useless; it covers pretty much anything that could be going wrong further behind the scenes. I stopped the SQL server, got this message. I stopped IIS, got this message. Not really helpful at all.


I know this question is old, But i ran into this issue as well while installing Sitecore commerce, But my issue was that TLS 1.0 on Sql server was not enabled, so i had to enable it on SQL server then restart the SQL server (Or service).

You can follow the link to enable TLS 1.0 on SQL server : https://support.microsoft.com/en-us/help/4077486/secdoclienthandshake-ssl-security-error-installing-dynamics-crm-server

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.