3

I have been following this guideline here and when I get to the step of running the http://localhost:5000/commerceops/InitializeEnvironment(environment='AdventureWorksShops') piece I noticed the following error message on the response:

"@odata.context":"http://localhost:5000/CommerceOps/$metadata#Commands/$entity","@odata.type":"#Sitecore.Commerce.Core.Commands.InitializeEnvironmentCommand","Id":"dd847fa373ca4958aa3a60f2873dc111","ResponseCode":"Error","Messages":[
{
  "MessageDate":"2017-03-03T22:53:51.1963137Z","Code":"Error","Text":"Entity Adventure Works Catalog|AW535-11| was not found.","CommerceTermKey":"EntityNotFound"
}

I did run the command http://localhost:5000/commerceops/Bootstrap() before that without any issues. Anyone know what I'm missing? I mean I need the Adventure works catalog to show in Sitecore. I"m not sure whether this is the step that imports considering the error message I"m assuming it's somewhat related.

If this is not the step and this message is just a consequence of a failed import my question would be in this case: which step imports it and what could cause this failing?

2

To fix this I had to import manually the catalog within the catalog manager in my case located at C:\Program Files (x86)\Commerce Server 11\Business User Applications\CatalogManager.exe

from there I had to select the catalog xml file on the folder \MySitecoreWebsiteFolder\SitecoreCommerce\Data\Catalog

From there I was able to see the adventure works catalog imported on the catalog manager

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.