I have 2 web solutions.

  1. Sitecore project
  2. Custom website that i would like to integrate in Sitecore as a dashboard module

What i did:

  1. I published my website in this folder: /sitecore/admin/Dashboard
  2. I added thoses exceptions "/signalr|/signalr/hubs" at the end of the IgnoreUrlPrefixes key in "Sitecore.config"

The result i get: enter image description here

The version i use: Sitecore.NET 8.2 (rev. 161221)

Am i doing something wrong or did i forget something ?


Looks like you haven't registered Owin startup class in your app-settings/web.config

The Owin startup class has to be supplied for the middleware software to be loaded, should also be explained in the SignalR documentation.

I have included sample settings from the supplied link.

Attribute on startup class:

[assembly: OwinStartup(typeof(MyStartupClass))]

App.config / web.config settings

    <add key="owin:appStartup" value="MyNamespace.MyStartupClass" />


This blogpost also has some examples/configurations on how to setup: https://community.sitecore.net/technical_blogs/b/exploring_sitecore/posts/signalr-and-sitecore

  • Hi Aliz Have you had the opportunity to try my suggestions? Mar 13 '17 at 13:28
  • Hello @Morten, sadly none of the solutions proposed worked :(
    – Aliz
    Mar 20 '17 at 19:55

Hum, there is likely a few ways to achieve this. And it's literally been years since I've twiddled with these settings myself. I would try this though:

  1. Place your DashBoard under /sitecore/DashBoard
  2. Add a new Site Definition, looking something like this. Make sure this is patched in before "website".


<site patch:before="site[@name='website']"
    name="admin" virtualFolder="/sitecore/DashBoard"
    loginPage="/sitecore/admin/login.aspx" />

Note: loginPage probably needs to be taken out. But ideally, you should make sure your custom web application inherits some of Sitecore's base page logic, so as to use a seamless login from the Sitecore client to your application, and to benefit from Sitecore permissions. That is a story for a different day however.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.