0

We are using Sitecore 7.2 and Coveo for sitecore in our multilingual CMS website. Our sitecore really gets slow sometimes and we could also see deadlocks happening in our application logs.

Upon analysis, We could see that there are almost 300000 records getting added in our EventQueue table of Core database. Sitecore recommends to have less than 1000 rows in EventQueue table.

Current CleanupEventQueue task is set to Run every 4 hours to remove the entries which are older than a day and so EventQueue table does not contain any entries older than a day.

We found that Property changed event is getting triggered for every coveo index last updated field change and due to this,a large number of row entries are added to the EventQueue table. This constitutes to almost 60% of the rows in the EventQueue table.

EventType : Sitecore.Data.Eventing.Remote.PropertyChangedRemoteEvent, Sitecore.Kernel, Version=7.0.0.0, Culture=neutral, PublicKeyToken=null

We followed the sitecore recommendation based on the article https://kb.sitecore.net/articles/930920 and added the required configs and library files. Even after adding the recommendation, we could not see the count of EventQueue rows getting reduced.

Can you please let me know if I am missing something.

Thanks, Karthik

  • Apply @sitecore climber 's patch. That should help big time with the ebentqueue entries. We had the same problem. Do you have a lot of workflow publishing happening? – Gabbar Mar 13 '17 at 20:59
  • @Gabbar I have already added the Modification of the Properties table does not respect EventDisabler article and kb.sitecore.net/articles/930920. But even after adding these, I am not seeing any difference. That is the reason, I need help. – Karthik Mar 13 '17 at 21:26
  • Are you using workflow publishing? – Gabbar Mar 13 '17 at 22:45
  • @Gabbar We are using scheduled jobs for automated publishing and we do not publish content manually. So content publishing is done at scheduled times. – Karthik Mar 14 '17 at 14:39
  • What are the settings on the scheduled publishing job .. is it incremental, smart or full-mode? – Gabbar Mar 14 '17 at 14:42
1

Every time an index update operation occurs, an index update timestamp is written to the Property table of the core database. This is a known issue related to this behavior.

This happens because Sitecore Content Search uses the Properties database table for storing instance specific search indexes metadata. For example, it stores the time of the last index update. Each change to the Properties table leads to PropertyChangedRemoteEvent being recorded to the EventQueue table to notify other connected Sitecore instances to update their caching layer around the Properties table. If the index updates are frequent enough, the aforementioned behavior may lead to excessive cache repopulation, and subsequent performance issues on both Content Management and Content Delivery servers.

Solution 1

As one of the options to address the issue, it is possible to implement the following solution:

  1. Apply the patch from the Modification of the Properties table does not respect EventDisabler article.

  2. Place the Sitecore.Support.417664.dll assembly to the /bin folder.

  3. Place the Sitecore.Support.DatabasePropertyStore.417664.config file to the /App_config/Include folder.

    For Sitecore 7.0 - 7.2: Sitecore.Support.DatabasePropertyStore.417664.config

    For Sitecore 7.5 and later: Sitecore.Support.DatabasePropertyStore.417664.v2.config

Patch details:

Because the information recorded by Sitecore Content Search using the Properties table is instance-specific, there may be no need in sharing the property change events among other Sitecore instances. The current patch uses EventDisabler to prevent excessive population of the EventQueue table.

Second solution you can find it here: https://kb.sitecore.net/articles/930920

  • I have already added the Modification of the Properties table does not respect EventDisabler article and kb.sitecore.net/articles/930920. But even after adding these, I am not seeing any difference. That is the reason, I need help. can you please let me know if I am missing something. – Karthik Mar 13 '17 at 21:27

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.