Using the Sitecore.Ship Deployment task in VSTS and it seems to pass and the log seems to indicate things are getting deployed but after the deployment is done, the items in the .update package are not in the Sitecore instance. Thoughts on where to debug or what to check?

 2017-03-16T18:54:44.5106368Z ##[section]Starting: Sitecore Ship

    2017-03-16T18:54:44.5416084Z ==============================================================================

    2017-03-16T18:54:44.5416084Z Task         : Sitecore Ship

    2017-03-16T18:54:44.5416084Z Description  : Deploy sitecore packages through Sitecore Ship

    2017-03-16T18:54:44.5416084Z Version      : 1.0.8

    2017-03-16T18:54:44.5416084Z Author       : Geert van der Cruijsen

    2017-03-16T18:54:44.5416084Z Help         : Version: 1.0. [More Information](https://github.com/Geertvdc/VSTS-Build-SitecoreShip)

    2017-03-16T18:54:44.5416084Z ==============================================================================

    2017-03-16T18:54:46.7284066Z ##[debug]VstsTaskSdk 0.6.2 commit b4160c33da0010bd83279e9ffa9bbf13bcbd1ce2

    2017-03-16T18:54:46.8304120Z ##[debug]Entering D:\a\_tasks\SitecoreShip_2a98c55b-3e29-4955-b6b8-f9a3dd88d0cb\1.0.8\sitecoreship.ps1.

    2017-03-16T18:54:46.8633993Z ##[debug]Env:INPUT_FILEURL: 'D:\a\r1\a\CI Dev\drop\Hydrogen\Project\Hydrogen.Project.Website.Tds\bin\Package_Release\Hydrogen.Project.Website.update'

    2017-03-16T18:54:46.8664038Z ##[debug]Env:INPUT_SITECOREURL: 'http://vmname.westus.cloudapp.azure.com/'

    2017-03-16T18:54:46.8674089Z Sitecore URL http://vmname.westus.cloudapp.azure.com/

    2017-03-16T18:54:46.8674089Z file URL D:\a\r1\a\CI Dev\drop\Hydrogen\Project\Hydrogen.Project.Website.Tds\bin\Package_Release\Hydrogen.Project.Website.update

    2017-03-16T18:54:46.8683993Z create httpclient

    2017-03-16T18:54:46.8919226Z file opened

    2017-03-16T18:54:46.9227821Z form content created

    2017-03-16T18:54:46.9227821Z before postAsync

    2017-03-16T18:55:21.5286835Z After postAsync

    2017-03-16T18:55:21.5426824Z {"Entries":[{"ID":"12687106-0218-41c4-98f7-fa475a85a01f","Path":"addeditems/master/sitecore/templates/site"},...

    2017-03-16T18:55:21.5676838Z ##[section]Finishing: Sitecore Ship
  • Have you tried installing the update package with UpdateInstallationWizard.aspx and checking if the changes are successfully reflected?
    – jammykam
    Mar 17, 2017 at 0:18
  • 1
    Yep, regular UpdateInstallationWizard.aspx worked. I am assuming once Issue #70 in the github project is resolved than it will work.
    – Colema18
    Mar 21, 2017 at 18:23
  • Putting this on hold for now. Please flag for reopening once question and answers have been updated.
    – Mark Cassidy
    Mar 23, 2017 at 23:44
  • updated the answer - if it still doesn't meet your standards, feel free to delete. I was just trying to post the answer that I found in case other's run into the same issue.
    – Colema18
    Mar 25, 2017 at 4:42

1 Answer 1


Looks like Sitecore.Ship in the latest branch does not support Sitecore 8.2 Update 2 yet and it is a known issue. https://github.com/kevinobee/Sitecore.Ship/issues/70

There is a pull-request from dharnitski that allows for 8.2 support - https://github.com/kevinobee/Sitecore.Ship/pull/69. The gist of it is the ProcessingMode needs to be set to All in 8.2 but this property doesn't exist prior to 8.2. So he uses reflection to see if we are 8.2 and if we are then we set it to All (which is 2147483647).

using System.Reflection;
using Sitecore.Update;

namespace Sitecore.Ship.Infrastructure.Extensions
    public static class PackageInstallationInfoExtensions
        public static void SetProcessingMode(this PackageInstallationInfo info)
            var prop = info.GetType().GetProperty("ProcessingMode", BindingFlags.Public | BindingFlags.Instance);
            if (prop == null || !prop.CanWrite)
                //Pre Sitecore 8.2 Update 2 Versions have no such property

            // ProcessingMode.All = 2147483647
            prop.SetValue(info, 2147483647);
  • 1
    Hi @Colema18. This is a link-only answer. Please refer to: meta.stackexchange.com/questions/225370/…
    – Mark Cassidy
    Mar 17, 2017 at 15:22
  • 1
    Not a link only answer - I stated that it is a "known issue" and linked to the issue. Not sure what more to add.
    – Colema18
    Mar 21, 2017 at 18:21
  • If I disable these two links, what answer is left?
    – Mark Cassidy
    Mar 23, 2017 at 23:42

Not the answer you're looking for? Browse other questions tagged or ask your own question.