1

When i try to install the update package(Sitecore 8.1 rev. 151003.update) in the installation wizard,all the items get processed but get stuck up in the last step (copying files).Hence the installation is not getting completed.

When i see the post installation error file (\temp__UpgradeHistory\Upgrade_Sitecore 8.1 rev. 151003_20170318T05502164),there are lot of errors saying "Access to the path is denied."

I have provided the full access to files in the IIS for IUSR user.

Please help me in resolving this issue

2
  • 1
    Can you try to add full access on the Network Service. Also, on the directories, make sure that these user types have access Mar 18 '17 at 9:18
  • 3
    What is the Identity of your Application Pool? Mar 18 '17 at 11:51
4

@Dheeraj First Please ensure you have folder("\temp__UpgradeHistory\Upgrade_Sitecore 8.1 rev. 151003_20170318T05502164") present in your website path.

Go to IIS and check application pool of your website. Also go to App pools advance settings and check for which account identity is set for the same.

  1. If You have installed using sitecore exe installer, it will be network service. you need to set security access permissions to the folder( "\temp__UpgradeHistory\Upgrade_Sitecore 8.1 rev. 151003_20170318T05502164") ideally you dont need to do this as Sitecore installation already do this for you.

  2. If you have yourself setup this site from IIS, it might be running using AppPool Identity. In that case you need to setup security permissions to the website folder (Right click Website folder--> Proerties --> Security Tab--> Edit permissions) Add --> Click Locations --> Select your computer name and then search below account

IIS APPPOOL\{your-website-apppoolname}

and set required permissions.

Hope this helps!

0

We had also encountered this kind of problem. I remembered that upgrade process executes commands under the App Pool account that was created for the site. In our case, AppPool was using the build in NetworkService account and this account only had read permission to the web folders. So you can do either of the following.

  • Switch to a specific domain account that would have permission to modify the website folder.
  • Or modify the security on the folder to give the NetworkService account modify permission.

Not the answer you're looking for? Browse other questions tagged or ask your own question.