7

I've got 2 developer sandbox instances of Sitecore 8.2, and in one instance the package works fine. However, in the other one, I'm getting this error while trying to install a package:

ManagedPoolThread #17 16:20:58 INFO Installing item: items/master/sitecore/media library/Images/articles/youre-driving-me-crazy/{993E4B00-B5A0-46FC-8135-2545A9472B22}/en/1/xml ManagedPoolThread #17 16:20:58 ERROR One or more exceptions occurred while processing the subscribers to the 'packageinstall:items:ended' event. Exception[1]: System.NullReferenceException Message[1]: Object reference not set to an instance of an object. Source[1]: Sitecore.ContentSearch at Sitecore.ContentSearch.SitecoreItemCrawler.IsExcludedFromIndex(SitecoreIndexableItem indexable, Boolean checkLocation) at Sitecore.ContentSearch.Pipelines.GetContextIndex.FetchIndex.<>c__DisplayClassb.b__3(<>f__AnonymousType22 <>h__TransparentIdentifier0) at System.Linq.Enumerable.WhereSelectEnumerableIterator2.MoveNext() at System.Linq.Enumerable.d__631.MoveNext() at System.Linq.Enumerable.WhereSelectEnumerableIterator2.MoveNext() at System.Linq.Buffer1..ctor(IEnumerable1 source) at System.Linq.OrderedEnumerable1.<GetEnumerator>d__1.MoveNext() at System.Linq.Buffer1..ctor(IEnumerable1 source) at System.Linq.Enumerable.ToArray[TSource](IEnumerable1 source) at Sitecore.ContentSearch.Pipelines.GetContextIndex.FetchIndex.GetContextIndex(IIndexable indexable, GetContextIndexArgs args) at Sitecore.ContentSearch.Pipelines.GetContextIndex.FetchIndex.Process(GetContextIndexArgs args) at (Object , Object[] ) at Sitecore.Pipelines.CorePipeline.Run(PipelineArgs args) at Sitecore.Pipelines.DefaultCorePipelineManager.Run(String pipelineName, PipelineArgs args, String pipelineDomain) at Sitecore.Abstractions.CorePipelineWrapper.Run(String pipelineName, PipelineArgs args) at Sitecore.ContentSearch.Pipelines.GetContextIndex.GetContextIndexPipeline.Run(ICorePipeline pipeline, GetContextIndexArgs args) at System.Linq.Lookup2.Create[TSource](IEnumerable1 source, Func2 keySelector, Func2 elementSelector, IEqualityComparer1 comparer)
at System.Linq.GroupedEnumerable
3.GetEnumerator() at Sitecore.ContentSearch.Events.PackagingEventHandler.OnPackageInstallItemsEndHandler(Object sender, EventArgs e) at Sitecore.Events.Event.EventSubscribers.RaiseEvent(String eventName, Object[] parameters, EventResult result)

I've checked the configs between the 2 environments and they seem to be the same. What specific configs should I be looking for, and what other settings should I look at to figure out what the problem is with this 2nd instance?

  • Are you using any Sitecore modules? – jammykam Oct 4 '16 at 22:53
10

As Rodrigo Peplau suggests, sitecore/admin/showconfig.aspx is good for viewing the entire merged Sitecore configuration. So you could use that as the basis for your comparison between the environments.

The error message indicates that you have a problem with handling the packageinstall:items:ended event.

The event is configured in Sitecore.config

The stack trace points specifically to it originating from the OnPackageInstallItemsEndHandler method in Sitecore.ContentSearch.Events.PackagingEventHandler

The handler is configured in Sitecore.ContentSearch.config

The exception occurs when Sitecore checks if the item being crawled is excluded from a given index. So You could also check the config files for each of the indexes that cover the master DB.

Alternatively the 'object reference' exception might mean that Sitecore is trying to index an item that doesn't exist. So I would check to see if item {993E4B00-B5A0-46FC-8135-2545A9472B22} ever actually got installed on the target DB.

3

At the problematic instance, check at the showconfig what are subscribing to the "packageinstall:items:ended" pipeline event - also it's good to compare if you have anything here not at the good instance.

If there's anything at the broken instance not at the good one, try removing this first and retest.

1

The templates of the items in the packages might be missing in the environment installation.

Also you can try disabling index updates while you run the sitecore package installation.

setting name="Indexing.UpdateInterval" value="00:00:00"

http://sitecoreblog.alexshyba.com/sitecore_installation_wizard_disable_search_index_update_during_install/

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.