1

We are using the Sitecore 8.1, and I have patched a field called categories in the coveo default Index configuration node to make it a facet.

 <configuration xmlns:patch="http://www.sitecore.net/xmlconfig/">
  <sitecore>
<coveo>
  <defaultIndexConfiguration type="Coveo.AbstractLayer.CoveoDefaultIndexConfiguration, Coveo.AbstractLayer">
    <fieldMap type="Coveo.SearchProvider.CoveoFieldMap, Coveo.SearchProvider">
      <fieldNames hint="raw:AddFieldByFieldName">
        <fieldType patch:before="fieldType[@fieldName='alltemplates']" fieldName="categories" isFacet="true" isExternal="true" isMultiValue="true" settingType="Coveo.Framework.Configuration.FieldConfiguration, Coveo.Framework" />
      </fieldNames>
    </fieldMap>
    </defaultIndexConfiguration>
    </coveo>
  </sitecore>
</configuration>    

After reindexing the web index, I see the categories as facet field on the CES server, and we were able to query it as facet field. With facet settings.

Randomly, this setting is lost on the index server, and it is no more a facet field.

Facet settings Lost

All we have to do is to re-index the web index to make it as a facet field again. Can anyone tell me if I am missing some other configuration in sitecore ?

  • Which Coveo for Sitecore version? 3 or 4? Which CES version? Any CM/CD setup? If you have multiple instances, all your instances should have that field, since when a rebuild on your other instances will override this field. Also validate that the field is not duplicated in your ShowConfig.aspx (and the patch:before is unnecessary, the order in the fieldMap is not relevant) – flguillemette Apr 7 '17 at 11:51
  • It is the issue with multiple instances as you said. Iaddedthe field on the publishing instance and resolved the issue. Thank you. – Ramakrishna Kudikala Apr 8 '17 at 12:38
1

You do not need to manually patch the config file to make a field facet, you can instead declare them in the facet/bucket folder of the Content Editor like you would do with Lucene: https://developers.coveo.com/display/SitecoreV4/Making+a+Sitecore+Field+Facettable

Then you would need to re-index yes. If the field is "all of a sudden" no longer a facet, then maybe you have conflicting configuration files.

Make sure your CD share the same configuration file as your CM.

Cheers, Simon

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.