0

AB Testing: In Test Definition Item under the Test Lab I have set the workflow as sample Workflow and workflow state as Awaiting Approval. But when I saved the item I am only getting "item has a test in draft" notification message. There is no submit option visible in experience editor's notification area. How can I get "Create a test" option?

  • I also have the problem of not appearing "Create a test" option and only appears "item has a test in draft" notification. Already changed to use this <setting name="ContentTesting.AlwaysShowTestCandidateNotification" value="true" /> Any help? – Ricardo Oct 20 '17 at 14:04
2

In Sitecore 8.1 and above there is a setting which can be turned on to allow the content authors to start test via experience editor.

Please add the below settings either as patch config file or You can edit the value in the config file (Sitecore.ContentTesting.config).

Setting name is “ContentTesting.AlwaysShowTestCandidateNotification”

| improve this answer | |
2

If you have set the Sitecore setting ContentTesting.AlwaysShowTestCandidateNotification to true but you still do not see the "Create a test" link, it may be because that link will only display if the current item does not have workflow. If you have workflow on the item, then you will need to use the workflow approach to content testing (which means you may need to create some custom workflow steps).

Sitecore's documentation for setting up a testing workflow step.

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.