I am using Sitecore version : Sitecore.NET 7.2 (rev. 140526) and Web form version 2.4.0 rev. 140117.

At the time of installing Web Forms for Marketers I am getting below error :

An item name cannot contain any of the following characters: /:?"<>|[]-

I have removed the value for the InvalidItemNameChars setting but still I am getting the same error.

<setting name="InvalidItemNameChars" value="" /> 
  • Verify that no other configs are patching this setting. The error string pulls the value directly from configs. Try running showconfig.
    – jrap
    Commented Apr 26, 2017 at 14:57

2 Answers 2


You need to disable ItemNameValidation. Add a config file to App_Config/Include named z.DisableItemNameValidation.config and put this in it:

<configuration xmlns:patch="http://www.sitecore.net/xmlconfig/">
      <setting name="ItemNameValidation">
        <patch:attribute name="value"></patch:attribute>

The reason for the error is your ItemNameValidation setting includes a - (dash). The default OOTB setting does not include this value in this setting.

The WFFM package contains one or more items which include a dash in the item name. Most likely your project has overwritten the default ItemNameValidation hence the reason you are getting this error when trying to install the package. The changes are possibly as part of solution along with encodeNameReplacements replacing spaces with dashes for SEO friendly URLs and I've blogged about this issue previously.

The solution is either:

  • Install the WFFM package on a clean Sitecore instance before deploying any of your solution specific customisations or,
  • Revert the ItemNameValidation back to it's default value of /:?"<>|[] whilst you install the package using either a patch config or removing your custom config/setting.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.