2

I am using Visual Studio Professional 2013, and Sitecore 8.1. My project is configured using the Good Old Web Service.

Whenever I try to add a new item, all I get in the dialog where I'm supposed to choose the template for the new item is a screen which reads "Loading...", like so:

like so

I tried uninstalling and reinstalling several versions, I am always getting the same behavior - effectively preventing me from adding Items through Sitecore Rocks.

Anyone has any suggestions?

  • 1
    Any errors logged in your Sitecore log files? – Mark Cassidy May 10 '17 at 12:06
  • Nothing, nada, zilch. This is a problem as a lot of the tutorials I'm reading about customisation of Sitecore Analytics use Rocks - I can't do much without the ability to add new Items. Surely there should be a log about this somewhere..? – Emanuele Ciriachi May 10 '17 at 13:39
  • 1
    what user did you use when you created connection to the site? Are you sure that it has a permission to read templates? – Artsem Prashkovich May 10 '17 at 13:39
  • It's a Sitecore administrator - the same one I am using in my day-to-day development. – Emanuele Ciriachi May 10 '17 at 13:40
  • I'll tr installing Visual Studio Express 2015 and see if I get the same error there. – Emanuele Ciriachi May 10 '17 at 15:32
1

What finally worked for me:

  • I uninstalled Sitecore Rocks;
  • I closed Visual Studio;
  • I searched my ENTIRE hard drive for "Sitecore Rocks" and deleted every single file and folder with this name. NOTE: a lot of those files live under C:\Users\[username]\AppData folder, so you will need the appropriate privileges to access them.

I reinstalled Sitecore Rocks and everything was fine.

| improve this answer | |

Not the answer you're looking for? Browse other questions tagged or ask your own question.