I have been working to get a Powershell script to execute through a workflow action in Sitecore and I'm running into an issue. Previously I was able to insert a new Powershell action from the provided template. Having it as a direct child of a Workflow state worked pretty well. When moving my content item to that workflow state, I got the "script running" dialog and things behaved accordingly. Made total sense and worked pretty well out of the box for me. Good directions were provided here: https://doc.sitecorepowershell.com/v/v4.5.0/workflows.html

I noticed when I moved this over to my production environment, the Powershell workflow action wouldn't run. I checked and my production environment was on (SPE) 4.3. My dev environment was still on 4.1. Just to see, I upgraded my dev environment to 4.5 and encountered the same issue of the action not running. Nothing in the logs that I could find.

Reading the release notes, it says there were some pretty significant security updates for 4.3. My going theory is that my workflow actions were previously mis-configured in regards to permissions and security but ran anyway. Now that there's a security update, what can I troubleshoot to help solve the problem?

What I tried:

  • I configured workflow command execute access on the Powershell Action item and assigned it to the right user group.
  • I've tried using a variety of accounts (admin and non) to pass the item into the workflow state.
  • I've tried making the action a direct child of a workflow command.

I'm on sitecore version 8.0 update 6.

Thanks for your time. Any pointers are appreciated! Given that 4.5 has the most up-to-date security, I would like to use that version.

  • Did you disable the password security feature on your dev machine to see if the issue is still encountered? You can patch the settings to "Allow". May 11, 2017 at 22:31
  • Thanks for your recommendation, Michael. You mean patching security for SPE itself? I just patched it with the UAC block from here. I saw the intended results but my Powershell Workflow Action still wouldn't run. May 12, 2017 at 0:20

1 Answer 1


Turns out that the error was introduced while refactoring for #757.

The templates PowerShell Script and PowerShell Script Workflow Action both contain a field called Script.

Unfortunately, for the PowerShell Script item the field contains the script text while the PowerShell Script Workflow Action item field contains an item reference (Droplink).

Workflow Action

The fix actually requires a new build. Release 4.6 should include #911 to address this.


SPE 4.6 has been released and includes addresses this issue.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.