14

Has anyone seen large wait times in SQL Server related to the Event Queue? Specifically, we are seeing ASYNC_NETWORK_IO being reported as a problem when accessing the Event Queue in SQL Server.

We have something like 50+ servers connected to the same core database, I am wondering if the rapid querying by all boxes is causing the issue.

This is using Sitecore 8.1 u3.

  • What version of Sitecore are we talking about here? EventQueue tuning options can be very version specific. – G Killian Oct 5 '16 at 13:07
  • Are you using SQL Replication on the Core database? That can cause a lot of network activity, too. – G Killian Oct 5 '16 at 13:21
  • No we have a single CoreDB – Michael Edwards Oct 6 '16 at 8:11
7

To be honest, I'm not sure if what I describe below will fix the ASYNC_NETWORK_IO issue. Seeing NETWORK_IO lets me think that the issue is more network or server related than being a real Sitecore issue.

However, we have also seen high loads due to EventQueue table activity. With the help of Sitecore Support we've come to this solution:

Clean EventQueue on CM more frequent:

<configuration xmlns:patch="http://www.sitecore.net/xmlconfig/">
    <sitecore>
        <scheduling>
            <agent type="Sitecore.Tasks.CleanupEventQueue, Sitecore.Kernel">
                <patch:attribute name="interval">00:30:00</patch:attribute>
                <DaysToKeep>
                    <patch:delete />
                </DaysToKeep>
                <IntervalToKeep>01:00:00</IntervalToKeep>
            </agent>
        </scheduling>
    </sitecore>
</configuration>

On CD, check the EventQueue less frequent and disable the EventQueue cleanup (as it's already been taken care of by the CM):

<configuration xmlns:patch="http://www.sitecore.net/xmlconfig/">
    <sitecore>
        <eventing>
            <eventQueue>
                <processingInterval>00:02:00</processingInterval>
            </eventQueue>
        </eventing>
        <scheduling>
            <agent type="Sitecore.Tasks.CleanupEventQueue, Sitecore.Kernel">
                <patch:attribute name="interval">00:00:00</patch:attribute>
            </agent>
        </scheduling>
    </sitecore>
</configuration>

Using these values means that published content can take up to 2 minutes before it becomes visible. But it should lower the load on the EventQueue table.

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.