3

I've got a strange error with a droptree field, it works for all items except those below a certain folder, as below.

enter image description here

Debugging with Chrome the last request before the null item is returned was to the content editor with a massive query string, and when i browsed to it i got an IIS error about querystring length, so i changed the web.config settings as below:

 <system.webServer>
 <security>
      <requestFiltering>
        <requestLimits maxAllowedContentLength="524288000"  maxQueryString="65536" maxUrl="65536" />
      </requestFiltering>
</security>
  </system.webServer>

and

 <httpRuntime maxRequestLength="512000"  maxQueryStringLength="65536" maxUrlLength="65536" />

still getting the issue, any ideas?

Sitecore 8.2 initial release

5
  • Have you tried browsing to that item in Content Editor and trying to select it there to see how many versions in current language it has? – Marek Musielak May 16 '17 at 10:24
  • it happens for any item under the "courses" folder, even newly created item with any template there are a large number of items in that folder, so I am thinking it relates to that – Ian Etherington May 16 '17 at 10:26
  • Well, I can tell you what it's not. It's not directly related to the number of items under courses. At least not on 8.2u2. I created an item with 25.000 items under it, and had no issue other than a bit of load time. Droptree picked it up fine. – Mark Cassidy May 20 '17 at 15:17
  • I am also facing the same issue, Have you resolved this issue? then please let me know. – Jignesh Savaliya Feb 21 '19 at 14:48
  • Can you create another folder and add a large number of new items? As @MarkCassidy has pointed out - that doesn't seem to be the issue and would eliminate it. Also, can you try recreating your courses folder and see what happens? – Justin Bradley Feb 22 '19 at 15:40

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.