7

Is anyone out there using the Sitecore Commerce 8.2.1 CTP 3 release VM? I am having a NuGet Package reference issue in the Sitecore.Commerce.Plugin.Sample project wondering if anyone has gotten past this:

Error: Unable to resolve 'Sitecore.Serilog.Framework.Logging (>= 1.0.0-alpha7-1019)' for '.NETFramework,Version=v4.5.2'.
  • What exact action of yours results in the error? Does it happen during the build, or?.. – Dmytro Shevchenko Oct 5 '16 at 14:42
  • it happens during the build, it also happens if I try and manually install the packages from package manager or when I tried to use the nuget.exe restore as suggested below. – Andrew Crowder Oct 5 '16 at 19:28
6

This is a known issue with restoring NuGet packages:

https://github.com/dotnet/cli/issues/3199

Currently, there seem to be at least two ways to "fix" it (kind of) that work with varying success rates:

  • Restore packages manually using Visual Studio's context menu for your projects;
  • Use NuGet 3.5 RC1 and restore the packages using the command line: nuget restore.
  • So i have tried both of these and keep getting the exact same message. Unable to resolve 'Sitecore.Serilog.Framework.Logging (>= 1.0.0-alpha7-1019)' for '.NETFramework,Version=v4.5.2'. I have also reached out to the Sitecore Commerce team but no response yet. – Andrew Crowder Oct 5 '16 at 14:40
3

So the answer was to remove this NuGet packaged manually by editing the project.json file. Apparently this package is not needed by the solution so removing it was safe. There must be an issue with the package because even when I readded it from NuGet it still errored. Something Sitecore will need to fix.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.