4

I followed the documentation about Sitecore Commerce installation. I finished configuring everything, then try to open storefront. It returns error something like "HTTP Error 502.3 - Bad Gateway The specified CGI application encountered an error and the server terminated the process." and requested url is " http://localhost:5000/api/GetBulkPrices"

This url is by default Commerce Authoring service. Then I tried with postman and send request and after 2min it returns same error. So that I changed Authoring request time out to 20min and it stills running. I don't thing this will take that much.

P.S: I can send request to other api methods and returns with success result. It seems configuration are correct. Does anyone any idea why it is taking too long?

  • This can be a little bit tricky to debug. Can you give an example of a API method that does work? Did you try any of the Catalog API methods? – Erwin Jun 8 '17 at 15:29
2

The problem got fixed by re-doing a part of the Commerce Authoring Service setup:

Run the Bootstrap on the service, which loads the environments from the data/environments directory in the physical location of the IIS service

Use a browser and call http://localhost:5000/commerceops/Bootstrap().

After this process was done, the website works.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.