15

I have the following error showing up in my log file:

> ManagedPoolThread #8 16:51:28 WARN  Authentication on CES Discovery service failed.
Exception: System.Net.WebException
Message: The remote server returned an error: (403) Forbidden.
Source: System
   at System.Net.HttpWebRequest.GetResponse()
   at Sitecore.CES.Client.WebClient.ExecuteRequest(String requestUri)
   at Sitecore.CES.Client.ResourceConnector`1.Request(String endpoint, Object[] parameters)
   at Sitecore.CES.Discovery.EndpointSource.GetEndpoint(String serviceName)

Little googling shows that it's somehow related to GeoIP lookup. We're not using any GeoIP lookup functionality though. Is there something I'm missing? Is there a config setting I need to disable that is ON by default and I just don't know it?

Thanks in advance!

  • 1
    I have been wondering for along time why this happened as well, but just haven't bothered to look into it. – Søren Kruse Oct 6 '16 at 5:15
19

This looks like it's part of the Device Detection feature within the Sitecore.CES configuration.

It's fair that you would want device detection yet not have the GeoIP feature of it enabled. Have you tried renaming the following two configuration files to disable them and see if that works?

  • App_Config/Include/CES/Sitecore.CES.GeoIp.config
  • App_Config/Include/CES/Sitecore.CES.GeoIp.LegacyLocation.config

If you don't want device detection at all, it can be changed by patching the following setting in Sitecore.CES.DeviceDetection.config:

<setting name="DeviceDetection.Enabled" value="true" />
  • Great - did you disable DeviceDetection completely or just disable the GeoIP files? – Kasaku Oct 6 '16 at 8:20
  • Disabled device detection altogether. – LonghornTaco Oct 6 '16 at 14:22
16

Ensure that the following setting in the Sitecore.Analytics.config file is set to false

<setting name="Analytics.PerformLookup" value="false" />
  • I don't know where I saw this before, but I lost the reference and I spent hours trying to find it again because I KNEW there was another setting that I had to patch but couldn't for the life of me remember what it was. Thanks so much, Phil! I'd upvote this again if I could. – Zachary Kniebel Nov 10 '16 at 3:31

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.