4

I am in the process of migrating my solution from VS 2013 to VS 2017. I installed the correct version of TDS (TDS 5.6.0.15 for VS 2017) and when trying to open the solution in VS 2017, TDS projects are not loading and throwing following error.

TDS - Project Target Framework Not Installed

Tried an option in the error dialog box to convert TDS project to .NET Framework 4.6.1 but it does nothing and TDS projects are still not loading. Not sure how to fix it.

Do I really need .NET Framework 4.0 installed on this machine?

Would appreciate if someone can chime in with a solution for similar migration.

Below is PropertyGroup node from Project definition file (.csproj).

<Project ToolsVersion="4.0" DefaultTargets="Build" xmlns="http://schemas.microsoft.com/developer/msbuild/2003">
  <PropertyGroup>
    <Configuration Condition=" '$(Configuration)' == '' ">Debug</Configuration>
    <Platform Condition=" '$(Platform)' == '' ">AnyCPU</Platform>
    <ProductVersion>9.0.21022</ProductVersion>
    <SchemaVersion>2.0</SchemaVersion>
    <ProjectGuid>{1a9cd7e6-633b-4cfd-a018-c68ce1f57482}</ProjectGuid>
    <TargetFrameworkVersion>v2.0</TargetFrameworkVersion>
    <SourceWebPhysicalPath>..\GexaNes.Web</SourceWebPhysicalPath>
    <SourceWebProject>{b8d502fa-286e-45e9-b41f-584dadd80d16}|GexaNes.Web\GexaNes.Web.csproj</SourceWebProject>
    <SourceWebVirtualPath>/GexaNes.Web.csproj</SourceWebVirtualPath>
    <TargetFrameworkVersion>v2.0</TargetFrameworkVersion>
    <EnableUpdateable>true</EnableUpdateable>
    <UseMerge>true</UseMerge>
    <SingleAssemblyName>GexaNes.TDS.Core</SingleAssemblyName>
    <UseWebConfigReplacement>false</UseWebConfigReplacement>
    <DeleteAppCodeCompiledFiles>true</DeleteAppCodeCompiledFiles>
    <LegacyFileReplacement>false</LegacyFileReplacement>
    <AssemblyName>GexaNes.TDS.Core</AssemblyName>
    <Name>GexaNes.TDS.Core</Name>
    <RootNamespace>GexaNes.TDS.Core</RootNamespace>
    <SitecoreDatabase>core</SitecoreDatabase>
    <SccProjectName>
    </SccProjectName>
    <SccProvider>
    </SccProvider>
    <SccAuxPath>
    </SccAuxPath>
    <SccLocalPath>
    </SccLocalPath>
    <EnableCodeGeneration>false</EnableCodeGeneration>
    <ManageRoles>False</ManageRoles>
    <AssemblyStatus>Exclude</AssemblyStatus>
  </PropertyGroup>
  ....
</Project>
  • Did you tried to update the .Net Framework to 4.6.1 of the different projects manually? Moreover can you try to update the targetFramework manually by editing the .scproj via notepad? – Hishaam Namooya Jun 14 '17 at 21:25
  • All my projects in solution are already configured for 4.6.1 in VS 2013. Yes, I also tried to edit .scproj manually but that is not working either. – kiran Jun 15 '17 at 16:43
0

I remember running into this issue a while back.

To address it I had to download manually the .net Framework on the corresponding version(in my case I think it was 4.5) and install it on my environment. After that the TDS project would load properly.

Hopefully this is an option on your side

| improve this answer | |
  • I tried that option but it didn't work. – kiran Jun 19 '17 at 15:53
0

I am able to resolve this by re-installing VS 2010. I had VS 2010 which I uninstalled as I am not using it anymore but after reinstalling it back, I am able to load TDS project correctly in VS 2017.

Someone mentioned here a repair option, which I didn't try but looks like it can resolve such issues. May be helpful.

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.