2

We are in the process of upgrading sitecore website from v7.2 to v8.2 and are not seeing the indexing manager links in sitecore control panel and Developer tab is also not showing up within content editor with builtin admin account login.

  • 1
    For the developer tab to show up you need to right click on the ribbon and select the developer from the list. It is hidden by default. About the link for the index manager, you mean the link to open the modal is not appearing or the indexes that you want to rebuild are not appearing? – Hishaam Namooya Jun 14 '17 at 19:30
1

Sitecore Developer Tab

By default, Sitecore hides the Developer Tab. In order to active the Developer Tab, you need to right click on the Content Editor Ribbon and select the Developer option from the list. Please see below screenshot.

enter image description here

Sitecore Index Manager Link

It may be that when upgrading to Sitecore 8.2 from 7.2, some items were not properly installed or have been missed.

  • Make sure that you have the Indexing Manager item under the path /sitecore/content/Applications/Control Panel/Indexing/Indexing Manager in the Core Database.

  • Make sure that the field Click is populated with the value indexing:runmanager.

enter image description here

UPDATE

Note that the index configuration has changed in Sitecore 8.2. In the different indexes (core, master and web), it makes use of the following configuration:

<configuration ref="contentSearch/indexConfigurations/defaultLuceneIndexConfiguration" />

And you need to make sure that all your custom indexes have this configuration. Moreover, the Sitecore.ContentSearch.Lucene.DefaultIndexConfiguration.config should be something as below:

enter image description here

  • Thank you @Hishaam for that method of bringing back the developer tab in 8.2. We tried with plain vanilla sitecore 8.2 update 3 core database and the upgraded core database. both had the indexing manager configuration as you described. but indexing options are not available in control panel and In the content editor ribbon, 'Rebuild All' button is showing the message - "Indexes Gallery failed to render index list' – vijay majeti Jun 15 '17 at 14:59
  • So, you have an error in your indexes. The type is not correct – Hishaam Namooya Jun 15 '17 at 15:01
  • Please see updated answer – Hishaam Namooya Jun 15 '17 at 15:19
  • Also please check the logs and share it – Hishaam Namooya Jun 15 '17 at 16:28
  • @vijaymajeti I will suggest to take a backup of your existing upgraded website and then replace your search config files with Vanila Sitecore 8.2 update 3 config files. It looks like there is some Search index config file error. – Mohit Dharmadhikari Jun 19 '17 at 2:00

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.