Got SOLR setup and working on my local machine with all my cores installed. Everything is functioning as intended when starting SOLR from Command Prompt via a "bin\solr start" command. However, I installed SOLR as a service via NSSM and while the service was created and is in place, the service will not start for some reason. The error I am getting back is as follows when I attempt to start the service:

Windows could not start the SOLR 6.5.1 service on Local Computer. The service did not return an error. This could be an internal Windows error or an internal service error. If the problem persists, contact your system administrator.

These are the steps that I followed when setting up Sitecore 8.2 (Update 3) with SOLR (6.5.1): https://www.norconex.com/how-to-run-solr5-as-a-service-on-windows/

I made sure that I have the JAVA_HOME environment variable in place with the correct path as variable, and I am using 64 bit version of JAVA while using the 64 bit version of NSSM as well when creating the service. Any help is appreciated to solve this issue!

  • Do you have different Java versions on your machine? – Hishaam Namooya Jun 20 '17 at 18:19
  • No. I only have Java 8 Update 131 (64-bit) installed. – Toby Gutierrez Jun 20 '17 at 18:20
  • 4
    Just adding 2 cents. I use Bitnami installer for SOLR. It installs all you need to run SOLR, one simple install. Installs it as a service for you. bitnami.com/stack/solr/installer – Chris Auer Jun 20 '17 at 19:32
  • 6
    I'm voting to close this question as off-topic because is not related to Sitecore, is related to SOLR – Vlad Iobagiu Jun 20 '17 at 21:07
  • 2
    My vote is to keep it open. SOLR is core to Sitecore and others will be looking for the answer to this question, when setting up SOLR with Sitecore. – Toby Gutierrez Jun 20 '17 at 21:24

The issue of services failing to start is mentioned on NSSM homepage: Users of Windows 10 Creators Update should use prerelease build 2.2.4-101 to avoid an issue with services failing to start.

  • I've tried using this release but still getting the service failed to start error. any alternative fixes to this? – Jay Oct 8 '18 at 11:52
  • That doesn't work for me either – Ivan Buzyka Nov 13 '18 at 8:45
  • For me, the problem was Java was updated to a new version, and the old version was removed. So the JAVA_HOME Windows environment variable was pointing to a path that no longer existed. Updating the variable to the new path fixed the issue. – Justin Jan 16 '19 at 18:11
  • I had similar issues. I realized I had a 32 bit jre installed, but had installed solr using 64 bit nssm. I installed via 32 bit nssm (the pre-release build still) and it worked. – tarun713 Mar 20 '19 at 19:58

Not the answer you're looking for? Browse other questions tagged or ask your own question.