If I rebuild any search index, whether through Indexing Manager, or programatically, the CPU pegs at 100% until the rebuilding operation completes. This happens on development machines and production server alike. It happens for a custom index as well as sitecore_master_index and sitecore_web_index.

Is this just standard behavior or is there some way the CPU usage can be managed?

Here's the configuration for the custom index:

<configuration xmlns:patch="http://www.sitecore.net/xmlconfig/">
      <configuration type="Sitecore.ContentSearch.ContentSearchConfiguration, Sitecore.ContentSearch">
        <indexes hint="list:AddIndex">
          <index id="publications_search" type="Sitecore.ContentSearch.LuceneProvider.SwitchOnRebuildLuceneIndex, Sitecore.ContentSearch.LuceneProvider">
            <param desc="name">$(id)</param>
            <param desc="folder">$(id)</param>
            <param desc="propertyStore" ref="contentSearch/indexConfigurations/databasePropertyStore" param1="$(id)" />
            <configuration ref="contentSearch/indexConfigurations/publicationsLuceneIndexConfiguration" />
            <strategies hint="list:AddStrategy">
              <strategy ref="contentSearch/indexConfigurations/indexUpdateStrategies/onPublishEndAsync" />
            <locations hint="list:AddCrawler">
              <crawler type="Sitecore.ContentSearch.SitecoreItemCrawler, Sitecore.ContentSearch">
                <Root>/sitecore/content/Insurance Research Items/Documents</Root>

Any advice would be helpful, thanks.

1 Answer 1


Pretty much as expected. Means your disks perform great and you have enough memory.

There is a setting; ContentSearch.ParallelIndexing.Enabled defined in Sitecore.ContentSearch.config you can try setting to "false". It would slow down your index rebuild time, but might make it less intense while running.

See also: https://community.sitecore.net/developers/f/6/t/3620

  • Thanks Mark... the ContentSearch.ParallelIndexing.Enabled setting did alleviate the max CPU usage. It caused the index to take about 50% longer, but it kept CPU usage to between 85%-95%. Thanks!
    – Steve
    Jun 27, 2017 at 15:57

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge that you have read and understand our privacy policy and code of conduct.

Not the answer you're looking for? Browse other questions tagged or ask your own question.