15

I have cleared the security cache on Coveo several times, verified the certs, the encryption key and the Coveo license.

I have also verified the password hash and physically gotten on the master and the mirrors of Coveo to reach the CM server in the config.

But yet we see a lot of traffic going to the core db to authenticate the Coveo user.

Has anyone else had these issues before?

Sitecore 8.1 update 3 Coveo July 2016 release (8388)

  • 1
    Which user is the Coveo user? Is this a custom user? – George Chang Sep 20 '16 at 15:13
  • the user you create to authenticate from the master and is in the coveo admin user role. – ASura Sep 20 '16 at 15:25
  • Do the logs show anything? The authentication typically happens on indexing when it's trying to retrieve the security information about an indexed item. – George Chang Sep 20 '16 at 18:54
  • nothing useful. Basically this has been going on for 2 years. I have completely flushed out the security including the certs and encryption key. – ASura Sep 21 '16 at 16:40
  • Can you reproduce this error consistently? Coveo support is usually very responsive. Does setting <securityEnabled>false</securityEnabled> address it at all -- that would mean Coveo honours the Sitecore setting for security on a database (which may be totally unreasonable, I don't know). I'm just thinking about this from some other angles. – G Killian Oct 7 '16 at 12:42
4
+100

I have never seen this before but here are some ideas I would try:

  1. Compare the security provider configuration on Coveo's admin tool against a working box looking for misconfigurations;

  2. Set this coveo user(temporarily) as a sitecore admin and see if this fixes the issue;

  3. Another thing I would try would be to go to the security configuration on the admin tool(http://youradminhosturl:8081/Configuration/Security/Security.aspx?sm=Roles) and add the coveo user as system administrator with full access on the index browser.

| improve this answer | |
  • Diego, these were all done including setting up new credentials, new encryption keys, flushing out the security cache, delete indexes and content on CES. Nothing helps. – ASura Oct 7 '16 at 2:49
  • 1
    that's weird. Not sure if you tried this as well but trying to isolate the problem, I would run a vanilla sitecore with the same coveo for sitecore versionrunning on the same Coveo instance you have and see if that causes the locking. if not, change the core database from the vanilla instance with your actual core and see what you get. Last but not least I would get a sql server profiler to gather more information on the calls being made to the database. You also mentioned you checked logs, Does that include CES, search api, rabbitmq logs as well? – Diego Oct 7 '16 at 3:19
  • Diego, this happens in a distributed sitecore farm and not single instance. Even then we checked all the things like encryption keys, license file and coveo user password. They all use the same core db. SQL profiler shows that there is a heavy load on the core db for the coveo user, most pass but there are a few that fail. We have run these checks multiple times by multiple resources. – ASura Oct 7 '16 at 14:21
2

I seem to remember encountering a similar issue when running Sitecore in Azure. After each deploy, the site is effectively running on a brand new machine and the Coveo connector would create a new Security Provider in CES. The password would fail and ultimately our Coveo user account in Sitecore would get disabled for too many login failures.

We ultimately solved this by creating the Security Provider in the Coveo interface, then specifying it in the Coveo.SearchProvider.config file. The XML path for the settings are sitecore/coveo/defaultIndexConfiguration. Specifically, you'll want to make sure to set:

  • SecurityProviderName
  • UserIdentityName
  • SitecoreUsername
  • SitecorePassword
| improve this answer | |
  • Unfortunately this is not the answer, we have replaced the security provider several times, including deleting and rebuilding it. – ASura Oct 7 '16 at 16:25
  • But, are you specifying it in the config? If so, this probably is a support ticket for Coveo. The fact you can specify the security provider came out of our issues with Azure. – Derek Dysart Oct 7 '16 at 16:37
  • Yes sir. Coveo has looked at this over a period of months. We had to finally close the ticket and implement a custom solution to unlock the Coveo user when its locked. That is the only way so far. – ASura Oct 7 '16 at 16:40
1

If your Sitecore admin account is not sitecore\admin or its password is not b or you changed its password recently, you have to set the Sitecore credentials in Coveo for Sitecore (see Configuring the Sitecore Credentials). This will update the <SitecoreUsename> and <SitecorePassword> nodes of your Coveo.SearchProvider.config file.

After the change, you need to index at least 1 Sitecore item for the credentials synchronization with CES to be done. You should also synchronize the changes to the config files on all your CD servers. The password is encrypted with the \Data\Coveo\ConfigurationEncryptionKeys\RijndaelEncryptionKeys encryption key. You should also ensure this key is the same on all the CM and CD servers.

Those credentials are set in a User Identity in CES that is used by the CES Security Provider to expand the Sitecore roles while indexing.

Source: https://answers.coveo.com/questions/4264/sitecore-admin-account-locking

| improve this answer | |
  • Thank you for the comment but this has all being done several times over and the same result exists. – ASura Oct 10 '16 at 14:27

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.