9

My web application has just been upgraded to Sitecore 8.2.4 in Stage and I am experiencing slow response from Azure Search.

The same application running in 8.2.1 gets results twice or even faster than 8.2.4.

Any ideas on how to troubleshoot this slowness?

6

Sitecore has come up with hotfix patch on the performance improvement of Azure search with Update 8.2 u4, did you try this??

2
  • I didn't know this hotfix patch. In fact, I am working with Sitecore for this for the past few weeks. – Chandra Sekaran V Jul 26 '17 at 15:12
  • @Icv77 : You can add this Sitecore patch and share how it goes. Mark it as answer if it makes any improvement. – Siva Sankar Jul 26 '17 at 20:22
1

One way to improve the performance is to create enough replicas (copies of the index) to handle the query load. A single replica Basic service is targeted to handle low single digit QPS(queries per second). If you go beyond the limits of the service, latency can certainly become an issue.

As far as tool is concerned then one nice way to troubleshoot is to get more details on use of Azure Search Traffic Analytics which can expose the search metrics that include data such as the number of queries per second over various timeframe as well as the latency metrics that we are seeing internally. You can look at this article for more detail on how to review traffic. https://azure.microsoft.com/en-us/blog/analyzing-your-azure-search-traffic/

1
  • Azure Search seems to be fine here. The query which takes 30 to 60 seconds through content search API usually returns results in less than 3 seconds when run inside Azure Search directly. Sitecore has accepted this as a bug with 8.2.4 and are working on a hotfix. – Chandra Sekaran V Jul 26 '17 at 15:14

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.