2

I have added one extra publish target for some reason. I want only admins to see this.This has to be hidden in both the places (publish window and DB switcher) for non admins.

4

You can achieve this by removing Read access to the Publish Target for the users.

  1. Open the Security Editor from Sitecore menu > Security Tools.
  2. Select the Everyone role from the Roles and users selector
  3. Expand /sitecore/System/Publishing targets node
  4. Select the option to remove Inheritance from the targets you wish to restrict access to.

Security Editor

The target will now be removed from database switcher and as a Publishing target for your regular users. Any user which is an Administrator will still have these targets available, since admin role ignores all security settings.

If certain roles need to have these targets available, you can grant access to those specific roles by granting "Read" access to them.

3
  • Does this also hides the publishing target from the Publishing Dialog? Jul 10 '17 at 13:11
  • 1
    Yes. The publishing targets are just "regular items" in the content tree. If the user does not have read access, the Item Provider will not return them and so they will not be displayed. Make sure you remove inheritance from the Everyone role.
    – jammykam
    Jul 10 '17 at 13:13
  • Great to know :) Jul 10 '17 at 19:34

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.