3

I've seen a world of different documentation on analytics settings, including Sitecore's docs and this StackExchange question. So I'm trying to get the best answer to this scenario.

We have a CM and two CDs. The CDs are load-balanced. There is a single domain involved (not multi-site). What is the best setting to use for each of the following on both CM and CD?

  • Xdb.Tracking.Enabled
  • Analytics.ClusterName
  • Analytics.HostName

Based on the reading I've done, here's what we ended up with so far:

  • CM: Tried setting Analytics.ClusterName to point to one of the CDs using a hosts file entry, got the YSOD Tracker.Current error. Ended up setting Xdb.Tracking.Enabled to false.
  • CDs: Set Analytics.ClusterName to match a localhost entry (the one used when installing Sitecore) and the Analytics.HostName to the domain name of the site. (What I didn't know before, setting Analytics.HostName causes the site to redirect to that domain).

But from a best configuration/best practice standpoint, is that right?

3

Xdb.Tracking.Enabled defines whether xDB will track any visitor data in the session. This should definitely be enabled on the CDs. On the CM, it is up to you whether you want xDB / personalization features to be available in its front end.

Analytics.ClusterName serves two main purposes:

  1. It is used as the identifier of the cluster that locks contacts in xDB;
  2. It is used by clusters to transfer sessions and jobs to other clusters.

I talked about this setting in detail here: https://sitecore.stackexchange.com/a/4971/104

In your case, I would set this setting to e.g. yoursite.com for your CD servers and to e.g. cm.yoursite.com for the CM. This way, the CDs are considered a part of the same cluster. Also, make sure to configure the Shared Session to be shared between the two CDs.

Analytics.HostName — since you only have one CD cluster, this setting is not useful for you and can be left blank.

  • Easily the clearest explanation I've seen to cut through the miasma. Thank you! – Ken McAndrew Jul 13 '17 at 9:50

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.