2

I'm progressing in a Sitecore installation on a Dev laptop.

SQL Server up-and-running, able to login as Sitecore / ..... to whom I gave Sysadmin.

So far, OK.

But the SIM connection string:

Data Source=MYMACHINE\MSSQLSERVER;Initial Catalog=master;User ID=AAAA;Password=BBBB

produces a:

"A network-related or instance-specific error occurred while establishing a connection to SQL Server. The server was not found or was not accessible. Verify that the instance name is correct and that SQL Server is configured to allow remote connections. (provider: SQL Network Interfaces, error:

25 - Connection string is not valid)

Note that it's finding the SQL Server instance I believe, because if I intentionally wrong the instance name, it produces a different:

26 - Error Locating Server/Instance Specified

Any idea?

  • Can you provide more information? Like is the SQL running in a different box or the same as Sitecore is installed? is SQL set in Mixed mode instead of Windows Authentication only? – Vinicius Deschamps Jul 14 '17 at 20:24
  • Yes it's all on my laptop, including SQL Server. When I go to the SIM logs, I see an additional information: System.ComponentModel.Win32Exception (0x80004005): The parameter is incorrect but perhaps it doesn't refer to a parameter of my connection string? I don't have many and they look correct? It would have been nice if this "parameter" had been named! I removed the "Initial Catalog" parameter, going minimalistic, here's my connection string: Data Source=MYLAPTOP\MSSQLSERVER;User ID=a;Password=b – Coeur Dusite Jul 14 '17 at 20:57
  • Are you getting this error when you set the connection string in SIM, or after the installation? – Matthew FitzGerald-Chamberlain Jul 15 '17 at 2:05
  • You say "SQL Server up-and-running, able to login as Sitecore / ....." - but have you verified you can log in to SQL Server using the same credentials as you use in your connection string? – Mark Cassidy Jul 15 '17 at 10:06
  • Yes Matthew in SIM, I couldn't get pass "SQL SERVER CONNECTION SETTING" . Mark: Yes I could from SSMS with the 'user=Sitecore' credentials, but.. you gave me the idea to try from a different client, like a Powershell script... and.. BINGO! I've poked around the connection string, removing all and noticed it was working these ways: Data Source=;user=Sitecore;password=thePassWord Data Source=MYLAPTOP\user=Sitecore;password=thePassWord but not this way: Data Source=MYLAPTOP*MSSQLSERVER*;user=Sitecore;password=thePassWord – Coeur Dusite Jul 17 '17 at 16:09
2

By default, SQL Server is only configured to allow Windows Authenticated connections. When using a "normal" connection string like the one you mention here, you need Mixed Mode authentication.

enter image description here

Setting Mixed Mode for the first time will force you to define the sa account and a password. For your dev box (and only your dev box) I would normally recommend just using this sa account in your local connection strings.

Last thing to be aware of is, that for SIM to work you need to ensure your local SQL is running as a local system account (not NETWORK SERVICE). This can be set up here.

enter image description here

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.