3

In the wiki it states that default url is http://habitat.dev.local/ and in App_Config\Include\Project\z.Habitat.DevSettings.config, it states that rootHostName = "dev.local"

If we implement default url name(as mentioned in wiki) using SIM. What should we give in "Site Name" and "Host Name" for local development set up? enter image description here

5

The hostname should be habitat.dev.local on your Sim installation.

In the site definition you have:

<site name="habitat" patch:after="site[@name='modules_website']" 
                  targetHostName="habitat.$(rootHostName)" 
                  database="web" 
                  virtualFolder="/" 
                  physicalFolder="/" 
                  rootPath="/sitecore/content/habitat" 
                  startItem="/Home" 
                  dictionaryPath="/sitecore/content/habitat/global/dictionary" 
                  dictionaryAutoCreate="false" 
                  placeholderSettingsRoot="/sitecore/layout/Placeholder Settings/Project/Habitat"
                  domain="habitat" 
                  allowDebug="true" 
                  cacheHtml="true" 
                  htmlCacheSize="50MB" 
                  registryCacheSize="0" 
                  viewStateCacheSize="0" 
                  xslCacheSize="25MB" 
                  filteredItemsCacheSize="10MB" 
                  enablePreview="true" 
                  enableWebEdit="true" 
                  enableDebugger="true" 
                  disableClientData="false" 
                  cacheRenderingParameters="true" 
                  renderingParametersCacheSize="10MB" 
                  formsRoot="{4BC8A78C-44A7-46EB-8126-040D3F12CAA0}"
                  loginPage="/login"
                  enableItemLanguageFallback="true" />
        </sites>

where the hostname is a concat between "habitat." and the value of variable rootHostName wich is dev.local . The site defintion is defined in file /src/Project/Habitat/code/App_Config/Include/Project/Habitat.Website.config

| improve this answer | |
0

You can install the habitat with your desired name, SIM does not allow http://habitat.dev.local/ instead it allows http://dev.habitat.local/

You don't need to worry, You can Install it as http://habitat.local/

enter image description here

If you have any issue installing, follow my answer Sitecore habitat setup

Set the desired hostname <sc.variable name="rootHostName" value="dev.local" /> in z.Habitat.DevSettings.config file, and run the commands to install the habitat

Once everything is finished and your sitecore and habitat is installed:

Go to IIS and add the Bindings for the http://dev.habitat.local/ And register the host name in the Host file as well, becuase when installing the habitat it does not register the dev.habitat.local

add in host file 127.0.0.1 dev.habitat.local

IIS and add the Bindings

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.