3

I have a folder which is a bucket and I'm using the search functionality to get the results. By default I have 4 facets on the right column: Template, Language, Author and Date Range.

enter image description here I see on the path: /sitecore/system/Settings/Buckets/Facets that there are a few out of the box facets there. I have tried to create a new facet but it's not showing on the facets column.

enter image description here

Anyone know what I'm missing? I will need to add 3 other facets so looking for a solution to this.

9
  • 1
    Can you make sure that field exists in the index (probably sitecore_master_index)? You can use luke (github.com/DmitryKey/luke) to see the contents of the index. Jul 17 '17 at 19:18
  • 1
    did you reindex sitecore_master_index before you search ? Jul 17 '17 at 19:32
  • yes I reindexed it
    – Diego
    Jul 17 '17 at 19:33
  • what is contenttype? is it a custom index field? Jul 17 '17 at 19:35
  • 1
    Also here is the official facet creation document on this topic.
    – Harsh Baid
    Jul 17 '17 at 20:02
0

The problem ended up being that the contenttype field was not getting indexed properly and the facets didn't work because of that. Also the facets will only show on the Search page facets if the facet does exist on the results

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.