1

I'm trying to install an instance with SOLR search provider but it fails with unauthorized error:

enter image description here

I suppose the reason is pretty simple, I've never set any SOLR credentials in SIM because I didn't manage to find the settings. I checked Settings and Advanced Settings dialogs but found no SOLR-related configurations. Am I missing something?

[Sitecore 8.2.4, Solr 6.6, SIM 1.5.0]

2
1

Assuming you have installed Solr using the Bitnami Wizard: To disable authentication, remove the LocationMatch section that you will find at installdir/apache-solr/conf/solr.conf Restart all services (Solr and maybe Zookeeper) after saving the changes. Now Solr won't ask you for credentials.

The Solr installer of SIM is not very clever, and if it fails after renaming the config fails, it won't be able to run again. You'll have to reinstall or revert the changes to the default Lucene configuration before you can run it again.

2
  • It works, thanks. Regarding SIM - I've noticed that as well. Reported here. – Serhii Shushliapin Jul 20 '17 at 13:05
  • I always wished that in SIM there should be an option to rollback the changes if any failure happens. Generally I take backup of bin and config folders and restore them. – tpkphani Nov 6 '17 at 10:13

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.