6

8.2 Update 4 (170614).

I have several instances that were installed via SIM tool and Sitecore exe. All of them have no records in the Experience Profile after several visits. I have contacts and interactions in Mongo. I have contacts in the reporting database. I have experience analytics (page visits, languages, etc..). Just no visits.

Nothing in the logs points me in the right direction.

The API call from EP does not error. Just no records.

I have rebuild the reporting database. It seems like 8.2 U4 has some extra steps required to make it work.

When I run this code from Adam Conn, I see it is processing items, but none show up.

ContentSearchManager.GetIndex("sitecore_analytics_index").Reset();
var poolPath = "aggregationProcessing/processingPools/live";
var pool = Factory.CreateObject(poolPath, true) as ProcessingPool;
var driver = MongoDbDriver.FromConnectionString("analytics");
var visitorData = driver.Interactions.FindAllAs<VisitData>();
var keys = visitorData.Select(data => new InteractionKey(data.ContactId, data.InteractionId));

Log.Info($"Analytics: {keys.Count()}", this);

foreach(var key in keys)
{
    var poolItem = new ProcessingPoolItem(key.ToByteArray());
    pool.Add(poolItem);
}

enter image description here

enter image description here

UPDATE: It looks like all the instance's analytics index are empty. Weirdest part is event a new SIM site is empty. Install SIM site, publish, change session timeout to 1 minute, visit site in incognito, wait. EP still empty in SIM site.

UPDATE 2: I switched over to SOLR thinking maybe its a lucene issue with the latest Sitecore update. But even on Lucene, none of the installs (SIM or EXE) will show any EP data. My current test site has 8 interactions to list, but shows none. The Analytics index is still empty.

UPDATE 3: I moved the indexes for 1 site from Lucene to SOLR and installed this tool. I was able to force records into the analytics index. On all other instances of 8.2 U4, I still have not found a solution. I have opened a support ticket.

  • Can you try not to use incognito and also if possible disable the robot detection? – Hishaam Namooya Aug 1 '17 at 18:55
  • @HishaamNamooya Still nothing. If you spin up a 8.2 U4 SIM site, do you get EP data? – Chris Auer Aug 1 '17 at 19:10
  • I'm still on Sitecore 8.2 U1. I will try to do it on the 8.2 U4 and see. I am not using SIM but will install a new sitecore instance and see. – Hishaam Namooya Aug 1 '17 at 19:12
7

I know the question for this is asking for 8.2 version but I figured I'd add this if anyone using Sitecore 9 has a similar question like me. It looks like the config pointed out by Chris Auer has been moved into the xconnect site. The xml node to change is <IndexAnonymousContactData>false</IndexAnonymousContactData>. I found it in two places and changed both to false and then anonymous users started showing up in the experience profile of the site. The files were ~/App_data/jobs/continuous/IndexWorker/App_data/Config/Sitecore/SearchIndexer/sc.Xdb.Collection.IndexerSettings.xml and ~/App_data/Config/sitecore/SearchIndexer/sc.Xdb.Collection.IndexerSettings.xml. More info can be found here and here are the official docs about it.

  • I was wondering where this was in xConnect. Good find. – Chris Auer Jul 26 '18 at 1:07
6

OK, the answer is in update 3 of 8.2. In the update, they changed the setting ContentSearch.Analytics.IndexAnonymousContacts from true to false. This makes it so the system ONLY tracks visitors that have been identified in xDB. Via a login, EXM or some other means.

This is in the config file Sitecore.ContentSearch.Analytics.config.

<!-- CONTENT SEARCH - ANALYTICS - INDEX ANONYMOUS CONTACTS This setting specifies whether anonymous contacts and their interactions are indexed. If true, all contacts and all their interactions are indexed. If false, only identified contacts and their interactions are indexed. Default value: false -->

<setting name="ContentSearch.Analytics.IndexAnonymousContacts" value="false"/>

8.2 Update 3 Release Notes

To improve performance and optimize indexing, in the Sitecore.ContentSearch.Analytics.config file, we changed the default value of ContentSearch.Analytics.IndexAnonymousContacts setting from true to false. We also updated the description of this setting to explicitly state that false is the new default value.

0

I have a similar issue after upgrading from 7.2.2 to 8.2.6.

I can see reports in experience analytics and not in experience profile. Verified configuration changes also and all are fine.

How to fix the issue:

Step 1: Open experience profile and open developer tools using F12. If you see below error then follow the resolving steps from Step 2.

Console error in experience profile

Step 2: Create a aspx page and use the below snippet in page_load method in code file of that page.

using System; using System.Collections.Generic; using System.Linq; using System.Web; using System.Web.Http; using System.Web.UI; using System.Web.UI.WebControls;

public partial class sitecore_admin_SerializeJson : System.Web.UI.Page { protected void Page_Load(object sender, EventArgs e) {

    var config = GlobalConfiguration.Configuration;
    ((Newtonsoft.Json.Serialization.DefaultContractResolver)config.Formatters.JsonFormatter.SerializerSettings.ContractResolver).IgnoreSerializableAttribute = true;
    lblsuccess.Text = "success";
}

}

Step 3: Keep this aspx page in website/sitecore/admin folder.

Step 4: Give folder permissions to data and website folders

Step 5: Open this aspx page in browser like "http://abc.com/sitecore/admin/file.aspx"

Step 6: Check experience profile page and you will see the data.

Note: This solution works only when you can see identification and contacts in mongo DB. When you visit any of the page the analytics mongo db track the identifiers and contacts.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.