9

A client wants to cut down on servers and since they do not use the Experience Platform I am wondering if i could just eliminate the Mongo server. There is as of now absolutely no data in the Mongo server. What settings do i need to change to not get flooded with errors when i turn it off? Is this even adviceble?

11

There are several things which doesn't work properly anymore. You can disable it in the config. Go to /App_Config/Include/Sitecore.Analytics.config and set Analytics.Enabled to false:

<setting name="Analytics.Enabled" value="false" />

You also need to comment out all MongoDB connection stings:

<add name="analytics" connectionString="mongodb://localhost/analytics" />
<add name="tracking.live" connectionString="mongodb://localhost/tracking_live" />
<add name="tracking.history" connectionString="mongodb://localhost/tracking_history" />
<add name="tracking.contact" connectionString="mongodb://localhost/tracking_contact" />
<add name="reporting" connectionString="user id=user;password=password;Data Source=(server);Database=Sitecore_Analytics" />

‌ Source (with additional information): https://kb.sitecore.net/articles/296641

With Sitecore 8.1 there is a new mode called CMS-only mode. You find all information about this here:

https://doc.sitecore.net/sitecore_experience_platform/setting_up__maintaining/experience_management/experience_management_an_overview

| improve this answer | |
5

Yes, you can disable xDB.

You need to add a patch file Xdb.Enabled and Xdb.Tracking.Enabled set to false:

<setting name="Xdb.Enabled">
    <patch:attribute name="value">false</patch:attribute>
</setting>
<setting name="Xdb.Tracking.Enabled">
    <patch:attribute name="value">false</patch:attribute>
</setting>

Make sure you also remove mongo connection strings.

| improve this answer | |
  • Please note this is an 8.1 setting only. Does not apply to 8.0 – Richard Seal Oct 6 '16 at 13:06
  • Thanks @RichardSeal . You're absolutely right. I've been working with Sitecore 8.1+ for so long that I already forgot it was different in 8.0 ;) – Marek Musielak Oct 6 '16 at 13:28

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.