2

For some reason, I am unable to get Sitecore Rocks Folder sync to work correctly.

I've set up the sync, and pointed to the related folder in the web directory, but changes are not being synced. Choosing "sync now" does not work.

I am pretty sure Rocks is connected correctly, as I can create new layouts in the solution explorer, and the related item appears in the Sitecore explorer. Not sure if it's a permissions issue, but I have tried adding "everyone" to folder in question just to test, and this did not help.

Logs seem show show file being deleted, and some random file appearing??

Logs

1

Sitecore Rocks uses the "robocopy" DOS command for mirroring the folder. Possibly this fails on your machine.

Try executing this from a command prompt:

robocopy [source] [dest] /mir /njh /njs /ndl /nc /ns /np /A-:R

1
  • Tried that, and works fine both on test folders, and on actual Sitecore view folders but still not via Rocks.. I am able to use a gulp tasks to do the same thing now, but still strange why this isn't working.
    – mp3duck
    Aug 17 '17 at 7:45

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.