5

The internal search stopped working. It was working fine until I configured Solr.

The changes I made are :

Disable all Lucene configs except the DefaultIndexConfiguration.config and enabled all Solr configs.

In the Solr DefaultIndexConfiguration.config, I have included some templates & fields in the respective nodes &

this is set to true - <indexAllFields>true</indexAllFields>

enter image description here

There are no exceptions logged and I've checked Search.log, Crawling.log and the regular log.txt

Also, when I try to rebuild indexes in the Developer tab, it shows none.

Using Sitecore 8.0 Update 5

8
  • did you login on solr interface ? can you see there solr core? – Vlad Iobagiu Aug 10 '17 at 5:59
  • @SitecoreClimber What is solr core. I can log into the solr interface and see all the custom cores I have created. There are no errors displayed there. – Qwerty Aug 10 '17 at 6:03
  • do you see master_index core into solr? – Vlad Iobagiu Aug 10 '17 at 6:14
  • Yes, I see sitecore_master_index & Sitecore_core_index – Qwerty Aug 10 '17 at 6:28
  • 1
    did you rebuild all indexes? – Vlad Iobagiu Aug 10 '17 at 6:44
1

You can try to check configuration with Sitecore Role Checker Tool: https://github.com/reyrahadian/Sitecore-Server-Role-Checker

If you use SOLR all Lucene files should be disabled and when you use Lucene you should disable all SORL configuration files. You shouldn't use SORL & Lucene configuration files in parallel.

0

When I first configured Solr, I disabled all Lucene configs except Sitecore.ContentSearch.Lucene.DefaultIndexConfiguration.config

Now, I enabled Sitecore.ContentSearch.Lucene.Indexes.Sharded.Master.config and its working fine now.

1
  • All Lucene files need to be disabled including Sitecore.ContentSearch.Lucene.DefaultIndexConfiguration.config – Mohit Dharmadhikari Aug 11 '17 at 9:56

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.