5

I have an issue with the following Module "Microsft Dynamics CRM Security Provider 2.1.2" I´m using Sitecore 8.0 with Microsoft Dynamics Office 365(online on Microsoft) I read all the documentation, and I could not find anything Related to OFFICE 365(Dynamics online) Connection string Syntax :(https://sdn.sitecore.net/upload/sdn5/modules/dynamics%20crm%20campaign%20integration/dynamics_crm_security_provider_module_guide_for_sc60-70-a4.pdf)

The release notes say that works with Office 365 (https://dev.sitecore.net/en/Downloads/Dynamics%20CRM%20Security%20Provider/2%201/Dynamics%20CRM%20Security%20Provider%202%201%202/Release%20Notes)

If I use the old crm connection string syntax. it works, and if I click on "user Manager", Sitecore User Manager works(get all CRM contacts)

OLD CRM Connection String SYNTAX https://crm.crmdev.XXXX.com/XXXX-dev/XRMServices/2011/Organization.svc;user id=Sitecore-myusername;password=pass@12345;organization=XXXX-DEV;authentication type=0" />

NEW OFFICE 365 CONNECTION STRING SYNTAX If I use the new connection string, my Sitecore "user Manager" is not able to get CRM contacts

https://clientsandbox.api.crm3.dynamics.com/XRMServices/2011/Organization.svc;user id=myuser;password=myusername2017;authtype=Office365" />

The documentation tells me that works, but this is not the case it´s not The logs files complaints about the structure of the ConnectionString

-Missing Organization Param

-Missing authentication type

But even if I adapt, still not working Do anyone knows if this Provider works with "Dynamics ONLINE Office 365"

Thanks

  • 1
    Are you getting errors in the logs? – Richard Seal Aug 10 '17 at 14:14
  • Yes, I´m the new CRM Connection string Syntax is not recognized – Jose Neto Aug 11 '17 at 21:19
  • @Jose, can you give a shot and see the answer from this post - sitecore.stackexchange.com/questions/2842/… – Vinicius Deschamps Aug 14 '17 at 12:36
  • Hi Vinicius, it does not work, if I remove the "organization" parameter, the log files complaint, "organization is missing" – Jose Neto Aug 14 '17 at 16:55
  • can you edit your question and add the log entries? – Vinicius Deschamps Aug 15 '17 at 14:21
3

Problem Solved

Solution: If you are using just Sitecore CRM Provider, you should use "authentication type=2", if you are using Microsoft.Xrm.dl then you should use authtype=Office365, if you are using both dlls on the project (since they do different stuff), you can use "authentication type=2;authtype=Office365"

Sitecore helped me on this issue (on the Sitecore part) but I suggested then to use the Microsoft Standard, to avoid this type of issue, anyway the solution would be using both Sitecore and Microsoft Parameter on the same ConnectionString

Final Connection string would be

<https://clientsandbox.api.crm3.dynamics.com/XRMServices/2011/Organization.svc;user id=myuser;password=myusername2017;authtype=Office365;authentication type=2 />
| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.