5

Still new to Sitecore..

I am making content changes in the master database (either via Rocks, or in the Content Editor), but if I refresh the page, I can see the changes without having to publish.

If I view item on "web" database, it's still showing the old content.. I've double checked my .... entry in my config file, and it's set to use "web"... I'm sure I am missing something obvious, but some pointers would be great.

6

You might have the database for your website set to master. To check this go to yourBaseUrl/sitecore/admin/showconfig.aspx. After that locate your site node and check the database attribute. This should tell you the file that is setting that attribute by mentioning the patch it is coming from (patch:source). If nothing is noted then it is coming from your Sitecore.config.

  • 1
    ahhh. my devsettings.config had this patch: <sites> <site name="mysite"> <patch:attribute name="database">master</patch:attribute> </site> </sites> that was the culprit - need to remember about this config patching feature. pretty powerful – mp3duck Aug 16 '17 at 15:32
  • Sweet glad that helped :). Ever since being shown patching I've been using it for any Sitecore config changes as that's the general standard (allows for more fluid upgrades). The problem I've had with it is finding where a setting is which is where the showconfig page shines. – Teeknow Aug 16 '17 at 15:34
1

You are running "Live Mode" - which is quite customary for development environments.

Described here: How to run Sitecore in Live Mode?

Essentially; Live Mode runs everything off the "master" database and is preferred by many developers to save the overhead of having to publish all changes all the time.

Your App_Config\Include folder will likely have a LiveMode.config that enables this. If you want to revert to normal Sitecore behaviour, remove or disable that file.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.