2

I want to enable 'Edit' button in the Sitecore ribbon. The problem is that this button is disabled for non-admins.

enter image description here

Please note the following things which might help to better understand the issue:

  1. The users that are facing this problem are in a custom role.
  2. This role is a member of 'Sitecore Client Developing' and 'Sitecore Client Authoring'
  3. For this custom role, I have already given 'Workflow State Write', 'Workflow State Delete' and 'Workflow State Execute' permissions.
  4. In the core database, I have also given all the necessary permissions to the edit button which I found at '/content/applications/content editor/ribbons/chunks/workflow edit/edit'
  5. In my config file, I have set 'AutomaticLockOnSave' to 'false' for some other purpose.

If I make a certain user an administrator, then the button gets enabled. However I would like to enable that button without elevating the user permissions to admin level. I am unable to understand which permissions I need to set in order to enable the Edit button.

Thanks for your help!

  • You need to give Write permission to the user on the item. For example, if the item is Home, from the Role Manager, select your custom role and set the Read, Write access. You may click on the Assign button above to set the Read, Write access to the descendants also. Note that you need to make sure that your custom role is not being overridden by other roles – Hishaam Namooya Aug 16 '17 at 19:44
1

You need to provide the Write access to the user in order for the Edit Button to appear. Note that, instead of setting the Write access on the user, you can set it on the Role itself.

Example

Let say you have a role named Testing Role. Open the Role Manager Dialog and select the role.

enter image description here

Once selected, click on the Security Editor. When the Security Editor opens, select the Parent Item and set the Read, Write access to it

enter image description here

Now, if you have sub items, instead of doing it one by one, you can click on the Assign button in the ribbon and then check the descendants as shown below:

enter image description here

This will automatically allows the sub items to be edited by any user who has the role Testing Role.

IMPORTANT NOTE

Sitecore role can override other roles. You need to make sure that when setting the read and write access, there are no other roles which are overriding it.

| improve this answer | |
  • Hi Hishaam, Thanks for getting back! I had already setup the role with write access. My guess is that 'AutomaticLockOnSave' is probably interfering in this case. But thank you so much for the pointer! – Akshay Mahajan Aug 17 '17 at 12:17

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.